Novhina

Reputable
Feb 14, 2016
6
0
4,510
0
Hey everyone,

My Nvidia Geforce GTX 960M card is recognized under Device Manager and in the nvidia control panel but it's not actually working. I manually set the games in Program settings to "High-performance NVIDIA processor". I also enabled "display icon in notification area" and it says the nvidia card is in use while my game is running.
However, my programs are actually using the Integrated intel card. I noticed this when i switched my games to use the integrated card and there was no change in the games' fps.

What I have tried:
Reset laptop
Updated windows 10
Clean uninstall of nvidia driver and reinstall
Updated nvidia drivers to latest one AND also tried rolling it back to previous version
Setting the games to "high-performance NVIDIA processor"

Any help is appreciated!! I can't think of what else I can do.

Edit 1: power is on high performance
 
Last edited:

Novhina

Reputable
Feb 14, 2016
6
0
4,510
0
Try to force the laptop to use the 960m in the Nvidia control panel, which can be accessed by right-clicking the desktop.
Thanks for the quick reply!

I set the Global settings to "High-performance Nvidia processor" under Manage 3D settings but it made no difference (if that's what ya meant)
 
Mar 2, 2019
75
4
45
3
It might not sound like a great solution, but have you tried uninstalling the CPU Video Driver if possible?

It could also be a problem with power management settings
 

Novhina

Reputable
Feb 14, 2016
6
0
4,510
0
It might not sound like a great solution, but have you tried uninstalling the CPU Video Driver if possible?

It could also be a problem with power management settings
I have not tried that! What would that help with out of curiosity?
And I'm running my laptop on high performance mode for the battery
 
Mar 2, 2019
75
4
45
3
Uninstalling the CPU Video driver would force your PC to use the only display drivers left - the GPU one, you also don't really need them if you're on a desktop

Power management settings - if your on Windows 8 or Windows 10 - have all those stupid laptop settings carried over onto desktops,

You actually have a laptop so that's irrelevant - but anyway - whenever you reinstall windows or set up your PC - you need to check that your set to maximum performance in your Control panel [view by small icons] -> Power Options ; you'll probably need to read through the tabs in there and set to maximum performance, minimal energy efficiency etc. wherever you can

Sometimes in laptops and even desktops the PC thinks its doing you favours by extending abttery life
 

Novhina

Reputable
Feb 14, 2016
6
0
4,510
0
Uninstalling the CPU Video driver would force your PC to use the only display drivers left - the GPU one, you also don't really need them if you're on a desktop

Power management settings - if your on Windows 8 or Windows 10 - have all those stupid laptop settings carried over onto desktops,

You actually have a laptop so that's irrelevant - but anyway - whenever you reinstall windows or set up your PC - you need to check that your set to maximum performance in your Control panel [view by small icons] -> Power Options ; you'll probably need to read through the tabs in there and set to maximum performance, minimal energy efficiency etc. wherever you can

Sometimes in laptops and even desktops the PC thinks its doing you favours by extending abttery life
I've set everything to max performance under power options! Hasn't made a difference unfortunately.
 
Mar 2, 2019
75
4
45
3
My laptop has the same GPU and I can't see what else to do sorry, you already have and keep GeForce Experience up to date etc... Hopefully someone else can help
 
Mar 11, 2019
2
0
10
0
I have a similar problem with my GT 650M, but I can't even get it to switch it to high performance Nvidia on the global settings.
 
Mar 2, 2019
75
4
45
3
One thing that works well with laptops is turning them off, taking the battery out, and holding the power button down for 10 seconds to hard reboot it, that miiiight help
 

ASK THE COMMUNITY