Question Nvidia graphics driver wont install after updating to 1903

Jan 12, 2019
20
1
15
0
Hello,

I updated my computer with the newest version of windows 10 1903.

after doing so, nvidia drivers no longer work. when I go to display adapter property's, it shows it's using "Microsoft basic display driver"

I've tried uninstalling the driver on my computer though ""apps" setting, I've tried tried using DDU to remove any lasting files of the graphics driver, I've also did a "reset this PC" and re-installed windows but still the same issue.

I have already deleted the old 1809 version of windows, so I cant just rollback.

when I use g force experience, it shows there is a driver to be installed, but every time I install it, it go's though as its installing, asks me to reboot, then shows there is still an install to be done still when I open it up again.

anyone know the issue/fix?

is there a way to get 1809 back on my system?

Thanks!

edit:
System specs
i5 2500
Gigabyte Z68AP-D3
DDR3 8 gb
Nvidia MSI GTX 1070
 
Last edited:
Jan 12, 2019
20
1
15
0
After uninstalling drivers and using DDU again, I went into CPU-Z and it showed my graphics card was plugged into my system. I tried installing the DCH driver you linked me too and after it finnished installing, my screen went pink and in cpu-z it didnt show my GTX 1070 was plugged into the computer anymore. I uninstalled the driver from the "APPS" menu and it reverted the driver and showed that I had the graphics card plugged in again. I was able to make changes to the Display adapter and change the hz to 144 as it was not able too before. I think im just going to leave it like this until a fix is posted

Please list your full system spec including the Make and Model of all components so someone can help you.

You most likely need the DCH version of the drivers from Nvidia NOT the standard version which you select under Windows Driver Type here:
https://www.nvidia.com/Download/index.aspx?lang=en-us
 
Jan 12, 2019
20
1
15
0
Hi, Just signed up to let you know I am experiencing the same problem! I have uninstalled all Nvidia drivers with DDU , reinstalled with latest Nvidia DCH drivers and it locks me into 60hz mode when my monitor can do 144hz. The only drivers that work for me are the ones windows update automatically downloads: 23.21.13.8813 (nearly 2 years old). I have a Nvidia 1070ti gtx and Intel 2600k... This has only been a problem since I updated to Windows 10 1903 (May 19) Update.
Im still having the same problem, I tried seeing if windows addressed the issue with a windows update, but still same issues are occurring, when you go to "Advance Display Settings" does it show Microsoft display adapter or does it say its your graphics card?

EDIT: Did some More Digging Found this Fix (https://nvidia.custhelp.com/app/answers/detail/a_id/4808?linkId=100000006499750 )

From this form : https://forums.geforce.com/default/topic/1108650/geforce-drivers/nvidia-gtx960-drivers-not-compatible-with-windows-update-1903-18362-86/5/

It looks like its an issue with Sandy Bridge CPU's
 
Last edited:

ASK THE COMMUNITY