Nvlddmkm.sys tdr error

konet

Distinguished
Dec 16, 2010
26
0
18,530
0
I upgraded from a 9800gx2 to a gtx 580 the other day, and since then, several seconds after loading a game, the screen will crash to black and require a reboot. Looking at dumps and such, I have traced the problem to a tdr error with the driver nvlddmkm.sys. I've tried everything I could possibly find on the internet to no avail. Tried older drivers, disabling nvidia sound drivers and a bunch of other things. One of the odd things about this is that I can run furmark seemingly indefinitely (max I've run it for is 25 mins), but 3dmark06 causes the crash instantly. Any thoughts? The only thing I can possibly think of would be a failing psu (mine's a 1000w that's about 2.5ish years old, but was plugged in when my old mobo actually caught on fire a few months ago. According to intel's monitoring software, the rail outputs on the 3.3v, 5v, and 12v rails are 3.27v, 5.04v, and 12.65v respectively), but that doesn't explain why furmark can run. Any thoughts?
 

konet

Distinguished
Dec 16, 2010
26
0
18,530
0
No I don't unfortunately. As an aside, if it does end up being the psu, how difficult are they to replace? It's the one piece of hardware I've never swapped myself before.
 

konet

Distinguished
Dec 16, 2010
26
0
18,530
0
My 9800gx2 still works fine, by the way. Does this rule out PSU, or is the difference in consumption enough that it still might be going bad, but not enough so to effect the 9800?
 

Helltech

Distinguished
Mar 5, 2009
3,349
0
21,160
190
The PSU is extremely easy to replace.

And yes... there is a very very slight difference between those two in regards to power consumption, and it might just be enough that a low quality PSU cannot handle it adequatly.
 
1. Did you uninstall the GFX drivers with the old card in place ? Then shut down, remove the card, install the new card, reboot and install drivers ?

2. If that doesn't solve, download OCCT and run the GPU test .... if it doesn't crash and burn, look at the voltage / temp graphs at the end of the 60 minute test and post any anamolies.
 

konet

Distinguished
Dec 16, 2010
26
0
18,530
0
On advice from a friend, I under clocked my gpu clock speed and gpu memory speed by about 50mhz each, and this delayed the problem to the point where it takes about an hour and a half of gaming to cause the crash. I ran occt for an hour and it reported no temperature anomalies (about 70c average temp). Apparently my card can't monitor voltage because I got no graph for that, and I can't alter the voltage in msi afterburner. If I leave the computer off for a while, I can get things to last a bit longer, which implies something is overheating, but I know for a fact that it isn't my gpu or cpu. Could my power supply, or something else on the mobo be overheating?
 

Similar threads


ASK THE COMMUNITY