Question nvme detected in bios but not working

Apr 16, 2022
1
0
10
0
Hey guys. I have a 1TB Adata XPG Gammix S41 nvme on which Windows was installed. I was installing some games and watching videos when Windows gave a green screen with a memory error message, after the PC restarted the nvme is no longer being recognized by Windows or Linux (I have dual boot). In the BIOS it is recognized, however when it is connected the BIOS takes a long time to load and even the Linux BOOT takes a long time. I've already tried to change the SATA mode, restore the default bios settings and change the PCI port. I have another nvme that works on both M.2 ports on the motherboard, so I believe it's not a problem with the M.2 slot. I've googled a lot, tried some solutions, but still can't come to a conclusion. Does anyone have any idea what might be going on or have had a similar experience? Thanks.

Hardware:
ROG STRIX B460-I GAMING
Crucial P2 1TB CT1000P2SSD8
XPG GAMMIX S41 1TB agammixs41-1t-c

OS:
Windows 11
Arch Linux


Edit:

I noticed that when the nvme is connected, the video card has a led on in the power connector. I don't know what the link is. I did a legacy boot (no UEFI) using a pendrive with linux mint that I had, I was able to access nvme, copy files, open files normally, erase the partition ( read and write operations worked), but I can't access it again. It seems that it works when it wants to.
 
Last edited:

ASK THE COMMUNITY