Question Nvme drive, not dected In bios.

Jul 16, 2019
2
0
10
0
Firstly I'm a total novice regarding these matters so I apologise before hand if my post is light on technical details. I recently bought a new computer and decided to build it myself. One area of the build which I've struggled with is getting the m. 2 nvme drive to dected in bios and windows. After lots of research I found a post on this forum which explained how to do it which worked. I followed these instructions
Removed all drives apart from m. 2 nvme.
BIOS->Boot->CSM (Compatibility Support Module)->Disable.
BIOS->Boot->Secure Boot->OS Type->Other OS.
Insert usb with windows installation.
F10 saved, reboot and go into BIOS again.

Above steps worked I loaded into the windows installer. From there I decided to format the nvme like I had done to my standard ssd to turn in into a GPT so I could install Windows. I ran disk part formatting but got an error msg saying words to the effect of this style of hard disk cannot be formatted as GPT. So I thought it best to start from scratch so I ran disk part again and 'cleared' the drive then restated the computer. The nvme would now not dected even though all the bios setting where the same. After doing some digging I believe I had deleted the uefi partition and the bios cannot detect the drive any more.
My question is assuming what I believe I have done wrong above is correct. How do I get bios to dected the nvme m.2 drive if there is no uefi partion on there.
 

ASK THE COMMUNITY

TRENDING THREADS