Question NVMe M.2 SSD not recognized ?

Shooka

Distinguished
Apr 20, 2014
10
0
18,510
0
Hello,

Im setting up a new NVMe SSD as an extra storage (not for boot),
when looking at the BIOS I only see "NVMe device not found", and it doesnt appear in windows either.
I've updated my BIOS to the latest.

From my own research it seems like all the components should support this. Any ideas what else I can do ?

Specs:
Silicon Power 512GB NVMe M.2 PCIe Gen3x4 2280 TLC SSD Solid State Drive
GA-AB350M-D3H
AMD Ryzen™ 5 2600X Processor
 
Oct 22, 2021
18
0
10
0
I have a HP G2 EliteDesk SFF, with PCIe x 16 and inserted a card I bought with a Non Volatile Memory Express, mounted on it
and it works when the Intel Chipset is above the minimum required hardware. This computer is as old as 2015.
I tried another without the minimum required chipset, and it did not boot when I made it a boot disk, but it could be used for ReadyBoost only. It showed as a disk, but not a bootable disk.
I am satisfied with my NVMe M.2 card, and I have the computer performance improved with good speed and no (not responding) problems.
 

Shooka

Distinguished
Apr 20, 2014
10
0
18,510
0
Make sure M.2 drive is properly inserted into M.2 slot.
Gold color contact pins should not be visible, if it is properly inserted.

BTW - which model Silicon Power 512GB NVMe M.2 ?
yeah i inserted it twice to make sure, its fully inserted as far as I can tell.

This is the full name as i bought it from amazon:
Silicon Power 512GB NVMe M.2 PCIe Gen3x4 2280 TLC SSD Solid State Drive (SP512GBP34A60M28)
 

ASK THE COMMUNITY

TRENDING THREADS