Question NVMe M.2 SSD showing as "unknown device" after removing it from PCIe/M.2 adapter card ?


Dec 25, 2013
I am having trouble where my NVMe M.2 SSD's which I was using in a Dell OEM M.2 PCIe x16 adapter. The adapter holds 4 NVMe M.2 Drives and were setup with bifurcation however were only pooled and not raided in a Dell system. Was working perfect however I wanted to put all of the drives in another system(not Dell OEM), I had removed all data and then took the M.2's out the card and inserted them into my system on M.2 Slots however none were showing except for in disk management as an unknown device with 20TB of space (these do not have 20TB, not even total combined). I have tried putting the PCIe M.2 adapter back in the dell system with the original drives however they do not show up at all now with that, only when now inserted into an m.2 slot.
I cannot create partitions etc, they do not show up in disk part, not in any windows install / boot and nor in the BIOS either, only in disk management as an unknown device.

From what I have looked up online this is normally an issue with hard drives / USB drives. I have tried all the basic fixes and even tested the drives in 3 different systems, all to the same conclusion.

Could these drives firmware's have been corrupted? I did not unpool them before removing as I thought they could just been reformatted in disk management or disk part.

Any help is greatly appreciated!