Question NVMe SSD Enclosure confusing issue

Jan 16, 2023
I've recently purchased an Asus Rog Strix Arion NVMe enclosure:

In it I've placed a 1TB Samsung PM9A1 NVMe drive . This drive is mostly an OEM Samsung 980 Pro from what I could gather online.
The drive is in good working order as I've just taken it out of my laptop after I've replaced it with a 2TB 980 Pro.

The issue happens when I try to use it on a Zenbook Pro Duo UX582HS 11th gen i9 cpu.
This machine has 1 USB 3.2 Gen 2 USB-A port and 2 Thunderbolt 3 USB-C ports.

The enclosure connects just fine to the Thunderbolt ports using a USB-C to USB-C cable. Windows recognizes the drive and shows all the partitions but with a yellow exclamation mark in "This PC".
The exclamation mark seems to be related to Bitlocker, something about the drive being encrypted but with publicly available keys on the drive.
Note: The yellow exclamation marks are not in Device Manager, but in "This PC", on each of the partitions on the eclosed drive.

Anyway, I can copy files to/from the enclosed drive just fine with a maximum speed of almost 800mb/s, but the issue is that this only works for a few minutes.
After these few minutes - which can be 5 up to 15 or so - I hear the windows ding sound that tells me a device has been disconnected. Then it dings again and the device connects again.

In the meantime I get a popup saying that:
"An unexpected error is keeping you from copying the file. If you continue to receive this error, you can use the error code to search for help with this problem.
Error 0x800701b1: A device which does not exist was specified
[Details about the file that was being copied when the transfer failed]
3 buttons: Try again, Skip, Cancel"

If I click Try again it starts working again, but this time for just 1-2 minutes or even for a few seconds.

After I do this few times, "Try again" stops working, meaning that no matter how many times I click it, the popup just comes back.

At this point, the enclosure keeps connecting and disconnecting continuously, I can hear a ding every few seconds.
Also when this starts happening, the enclosure appears and dissapears from Device Manager, and when it appears it stays there for 1 second or so, then it gets an exclamation mark, then it dissapeares.

Event viewer (in Windows Logs -> System) says a few things:

Warning: "{Delayed Write Failed} Windows was unable to save all the data for the file [path-to-file]. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere"
Warning: "The system failed to flush data to the transaction log. Coruuption may occur in VolumeId: G:, DeviceName: \Device\HarddiskVolume234"
Both of the above warnings refer to the source file - the one on the encosed drive.

Warning: "The IO operation at logical block address 0x21c5aec0 for Disk 1 (PDO name \Device\000001dd) was retried"

I'm using the USB-C to USB-C cable provided in the box with the Asus Arion enclosure.
I seem to have misplaced the USB-A to USB-C cable that was provided so I cannot try that one. I'll probably go and try to find such a cable at a nearby store.
However, i'm using the same cable and same enclosure on an Asus Vivobook Slate Oled:
I did try the USB-A port with a USB-A to USB-C adapter in which I've put the USB-C to USB-C cable connecting to the enclosure but it does the same thing.

This machine has 2 USB-C 3.2 Gen 2 ports and the enclosure works very well on it, albeit I could only get speeds up to 600mb/s or so.
Interestingly enough, windows doesn't show the yellow exclamation marks on the partitions in "This PC" when I connect the enclosure to the Vivobook.

I've tried to connect the enclosure to a Macbook pro but no success, the macbook doesn't say anything and doesn't show the partitions anywhere. However this doesn't matter to me as I'm not looking to use the enclosure on any mac.

I've just installed windows 2-3 days ago.
Another thing to note is that I've installed all drivers provided by the manufacturer on the Zenbook Duo, including Intel RST (Managed and non-managed) when I've installed windows.
I've also installed the Intel thunderbolt drivers from the manufacturer.

Device Manager shows that on both the Zenbook and Vivobook the enclosure uses the same Microsoft driver.
The only difference in drivers is that the Vivobook does not have the Intel RST drivers installed because it doesn't need them. However the Zenbook does need them for the internal NVMe drive to work.

I've also tried disabling the USB power saving options, but I get the same result.

What could this be?
Is this USB 3.2 Gen 2 enclosure not supposed to work on Thunderbolt 3?

Thanks for reading this very long message.
Jan 16, 2023
Thank you for replying,

Did you take note of the temperature?
Well, sort of. Not with a thermometer but touching it it is barely warm.

Is the SSD reporting any Data and Media Integrity Errors via SMART?
No, I've tested with Samsung Magician prior to taking it out of the laptop.

Can you test the enclosure with a regular USB 3.0 port?
No, I don't think I have anything with a 3.0 port.
Jan 16, 2023
Thank you for the link. I've read some of those 39 pages and it seems that at least I'm not the only one having issues with NVMe enclosures. I was starting to think there is an issue with my laptop.
What I could gather is that I need to check if I'm using the Realtek RTL9210 a/b chip since this is reported to be mostly reliable, and then I actually need better thunderbolt cables because sometimes those that come with the enclosures are not very good.

In the meantime I've had a closer look at the provided cable that I'm using and it has some markings saying "USB 3.1 Cable".
Jan 16, 2023
Update on this issue:
So I managed to find a Thunderbolt 3 cable rated for 20Gbps, it's a Promate Thunderlink C20+.

Well the problem persists. I've also tried Ubuntu on the same laptop. Here, when I connect the Asus Rog Strix Arion , I just get a continous series of dings, one every couple of seconds, and the drive or its partitions don't show up anywhere.

I've connected a Samsung T7 on the same cables and it works just fine.

I have a USB 3.2 Gen 2 cable on the way, I'm curious if the issue will also persist over the USB A port.
Jan 16, 2023
Issue update: The Asus Rog Strix Arion works but only on a usb 3.2 port, not thunderbolt.

So I've just received a new USB 3.2 Gen 2 cable rated at 10Gbps. These are the exact specs of the Asus Rog Strix Arion ssd enclosure and this is a USB-A to USB-C cable, but I wasn't very optimistic given my previous experience with the device.

However to my surprise it seems to work well, as I've just copied 326,945 files amounting to 134 GB, without any issues whatsoever. During this copy, I got speeds of over 700mb/s.

I'm still not sure what causes this issue, but I suspect that perhaps the Asus Rog Strix Arion does not correctly negotiate the link type with the OS, so the OS tries to communicate at thunderbolt 3 speeds, but the ssd enclosure fails to operate at that speed, hence the disconnection and reconnection.

I'm going to use the Rog Strix Arion ssd enclosure more heavily during the next few days. I will post an update whether it works without issues or not.