Question NVMe ssd not detected by BIOS or Windows

Sep 8, 2021
2
0
10
0
Hello

I have a new build which i've almost finished.

The specs include
CPU - Ryzen 5 1600x
GPU - 1060ti 5GB
RAM - 24GB ddr4 RAM
Motherboard - MSI Tomahawk B450
SSD - 1TB Western Digital SN550 (NVMe)

Everything is working and i've got the PC running using my old SATA SSD
But neither the BIOS or Windows is picking up the new NVMe hard drive

I've tried updating the Motherboard drivers
Reinstalled the SSD
Booted with and without the old hard drive
Reinstalled windows 10

I already sent one of these hard drives back for testing and it came back as working, so I now have another one to try again and the SSD itself probably isn't the issue

So I'm guessing that it's either the motherboard (hopefully not lol)
Or I'm doing something wrong

Can anyone offer any help?
 
Hello

I have a new build which i've almost finished.

The specs include
CPU - Ryzen 5 1600x
GPU - 1060ti 5GB
RAM - 24GB ddr4 RAM
Motherboard - MSI Tomahawk B450
SSD - 1TB Western Digital SN550 (NVMe)

Everything is working and i've got the PC running using my old SATA SSD
But neither the BIOS or Windows is picking up the new NVMe hard drive

I've tried updating the Motherboard drivers
Reinstalled the SSD
Booted with and without the old hard drive
Reinstalled windows 10

I already sent one of these hard drives back for testing and it came back as working, so I now have another one to try again and the SSD itself probably isn't the issue

So I'm guessing that it's either the motherboard (hopefully not lol)
Or I'm doing something wrong

Can anyone offer any help?
Tried to update the motherboard bios to the latest? Try to while not plugging the nvme drive in, and after updating the bios, go to the bios and set your settings again, then shut down, place the nvme, and try to bootup again. Also after doing it try to disable csm on bios, plug the hdd anywhere from slot 1 to 4.
 

ASK THE COMMUNITY

TRENDING THREADS