Question NVME SSD not showing up in BIOS or Windows ?

Sep 16, 2022
1
0
10
0
Hi, I recently installed a Samsung 980 SSD M.2 PCIe 3.0 x4 (MZ-V8V500BW to be exact) on my Gigabyte x470 Aorus Gaming Ultra mainboard.
However, I couldnt get it to show up in the BIOS, or in Windows/Disk Manager.
My mainboard features two M.2 connectors:
  1. 1 x M.2 connector (Socket 3, M key, type 2242/2260/2280/22110 SATA and PCIe 3.0 x4/x2* SSD support) (M2A_SOCKET)
    * Actual bandwidth may vary by CPU.
  2. 1 x M.2 connector (Socket 3, M key, type 2242/2260/2280 PCIe 2.0 x4/x2 SSD support) (M2B_SOCKET)
The way I understand it they should both work, however i tried both to no avail. The mainboard manual says nothing about shared bandwith with SATA connectors.
So far I tried:
-disconnecting all SATA devices
-changing BIOS settings i read could have an effect (secure boot is off, CSM/boot/storage priority tried every setting)
-reinstalled windows (because why not)
-BIOS version is newest (F63c)
-chipset drivers are up to date

Idk if this is relevant, but I installed the SSD while upgrading my CPU from a R5 2600x to a R5 5600x. This is also why the BIOS was already updated.

Im on the brink of returning the SSD as faulty, but I wanted to ask if there is anything else that i can try.
Or if i somehow missed some obvious compatability problem. Then I wouldnt want to buy the same one again, (The regular 980 isnt on the compatability list for the X470, but the pro variants and other comparable ones are).

Any help is appreciated!
 

ASK THE COMMUNITY

TRENDING THREADS