Jul 13, 2021
1
0
10
0
Hello, 2 months ago I bought a WD_Black SN750 NVMe SSD, I moved my Windows 10 to it and have been using it every day without problems. I recently upgraded my GPU from RX 580 to 6700 XT and ever since then the drive has been randomly disconnecting. There's no regularity to it, sometimes it disconnects during use, sometimes during idle, sometimes it will boot without being detected either in windows or UEFI. Please look below for my setup and solutions I've tried.

PC (no OC):
CPU: Ryzen 7 3700X
MOBO: ASUS X570-P
RAM: 16GB DDR4
GPU: AMD RX 6700 XT (reference)
3 x SATA SSD, 1xSATA HDD
2 Monitors

PSU: Seasonic M12II 520W 80+ Bronze

Solutions Tried:
-Reset CMOS
-Switch M2 port
-Clean Connectors
-Full drive format, remove partition table, reinstall Windows (if running as C it will BSOD with code 0 when it disconnects, when used as secondary it will just lose connection, partition still visible in windows but "A device which does not exist was specified" pops up when accessing files)
-Reinstall chipset and GPU drivers
-Restore BIOS defaults, change mode to Gen3
-AHCI ON, Boot Compatibility ON
- WD dashboard S.M.A.R.T data shows no critical temperatures ever, no degradation, 100% health, S.M.A.R.T test shows no problems either

I'm quickly running out of ideas, is it possible that the GPU upgrade pushed power use close to PSU's limit and the SSD voltage gets unstable ? (I played RDR 2 at ultra for a few h and it didn't crash tho) How would I go about checking that without replacing the PSU ? (yet)
Thanks in advance for help.

Update: Checked voltages on open hardware monitor, managed to even capture the moment when the drive stops working, they are as stable as they get, avcc fluctuates between 3.36 and 3.37 but thats normal I think. I just realized the GPU wasnt the only change I made that day, I also got an active Displayport to DVI adapter, unplugged that and so far the SSD is working, if that turns out to be the culprit I will be confused, is it possible that's it ? Maybe the "pin 20" problem in some form ?

Update 2: The adapter was feeding 3.3v power from my usb thru displayport pin 20 into my gpu, knock on wood but 3h since taping the pin over and the drive seems to be working flawlessly, typing this with the NVMe as my C:
 
Last edited:

ASK THE COMMUNITY