Question nvme ssd to PCIe x4 not working

Sep 21, 2021
12
2
15
0
hey

i just brought and revived my samsung EVO plus and a m.2 nVMe SSD adapter card (Silver stone ECM24-ARGB) so i go to download windows (ghost spectre) everything goes well until it reboots then the drive doesn't show up the windows download page is the only place it shows up it doesn't up in THIS PC, disk management, cmd in windows it only shows up when im downloading windows then when it boots it goes away


my MOBO is: gigabyte g1 sniper b5
my ssd: Samsung 970 EVO plus
Adapter: Silver stone ECM24-ARGB m.2 nvme ssd to PCIe x4
 
Try flash this bios (copy file to flash drive and plug it on top rear usb slot, go to bios and click on q-flash) (latest and have nvme driver) and then reset/load default bios settings, dont forget to disable CSM support (use windows 8 whql or disable csm support, just do uefi only) after load defaults. then boot to windows.

and install the latest chipset driver then reboot, go to windows settings and check if there is any update and optional updates, install them.
 
Last edited:
Sep 21, 2021
12
2
15
0
Try flash this bios (copy file to flash drive and plug it on top rear usb slot, go to bios and click on q-flash) (latest and have nvme driver) and then reset/load default bios settings, dont forget to disable CSM support (use windows 8 whql or disable csm support, just do uefi only) after load defaults. then boot to windows.

and install the latest chipset driver then reboot, go to windows settings and check if there is any update and optional updates, install them.
thank you soo much bro i will try this now and see does it work :)
 
Reactions: Koekieezz
thank you soo much bro i will try this now and see does it work :)
Yup, i inserted the nvme dxe module just to see if it worked on yours, might not be seen on bios, but with the steps i gave (flash the bios i gave and reset bios settings to default, set sata mode to AHCI, bios to UEFI Only (disable any csm things) and disable fast boot, save and exit) it might work. if there is a bios fail, you could shhut down your pc, press power and reset button 11 seconds (while psu is not turned off, it will on and off for like 2 times), release, and power on like usual. it will kick the backup bios and you're back to normal, just for safety measurement :D

*also you could make bootable drive with nvme to pcie adapter with that modded bios, just make sure sata mode ahci, csm/legacy support all off, just do uefi only, and fast boot off. install the windows in nvme, and bam, your nvme drive appear now in bios.
 
Last edited:
Sep 21, 2021
12
2
15
0
Yup, i inserted the nvme dxe module just to see if it worked on yours, might not be seen on bios, but with the steps i gave (flash the bios i gave and reset bios settings to default, set sata mode to AHCI, bios to UEFI Only (disable any csm things) and disable fast boot, save and exit) it might work. if there is a bios fail, you could shhut down your pc, press power and reset button 11 seconds (while psu is not turned off, it will on and off for like 2 times), release, and power on like usual. it will kick the backup bios and you're back to normal, just for safety measurement :D

*also you could make bootable drive with nvme to pcie adapter with that modded bios, just make sure sata mode ahci, csm/legacy support all off, just do uefi only, and fast boot off. install the windows in nvme, and bam, your nvme drive appear now in bios.
i did that but i get "the computer restarted unexpectdly or encountered an unexpecter error windows click OK to restart the computer" when i do the bios and it keeps on looping?
 
Sep 21, 2021
12
2
15
0
Yup, i inserted the nvme dxe module just to see if it worked on yours, might not be seen on bios, but with the steps i gave (flash the bios i gave and reset bios settings to default, set sata mode to AHCI, bios to UEFI Only (disable any csm things) and disable fast boot, save and exit) it might work. if there is a bios fail, you could shhut down your pc, press power and reset button 11 seconds (while psu is not turned off, it will on and off for like 2 times), release, and power on like usual. it will kick the backup bios and you're back to normal, just for safety measurement :D

*also you could make bootable drive with nvme to pcie adapter with that modded bios, just make sure sata mode ahci, csm/legacy support all off, just do uefi only, and fast boot off. install the windows in nvme, and bam, your nvme drive appear now in bios.
View: https://imgur.com/b9DGs0G
 
i did that but i get "the computer restarted unexpectdly or encountered an unexpecter error windows click OK to restart the computer" when i do the bios and it keeps on looping?
so update is comepleted (bar at 100%) then it restart suddenly? then the update completed

Also forget to mention
If your windows installed on legacy on/first, then probably you'll ecounter this kind of bootloop (yeah i ecountered this problem once, legacy to uefi without reinstalling windows and bam bootloop, go back to legacy bam boot to windows), try to enable the CSM and any legacy option, with Legacy and uefi option.

did you update via q flash in the bios or using @bios? could you go to windows after this bios update before bootloop?

Reset bios to normal: shut down pc, press power + reset/resart or 11 secs (it'll go on and off repeadly), then power on like usual.

apologize my mistakes 🙏
 
Last edited:
Sep 21, 2021
12
2
15
0
so update is comepleted (bar at 100%) then it restart suddenly? then the update completed

Also forget to mention
If your windows installed on legacy on/first, then probably you'll ecounter this kind of bootloop (yeah i ecountered this problem once, legacy to uefi without reinstalling windows and bam bootloop, go back to legacy bam boot to windows), try to enable the CSM and any legacy option, with Legacy and uefi option.

did you update via q flash in the bios or using @bios? could you go to windows after this bios update before bootloop?

apologize my mistakes 🙏
all good man yea so basicly in the bois it went to 100% then restated and was stuck i will turn legacy option and uefi
 
Last edited:
no luck bro but i launched my other drive and went to device manager and under other devices if shows up there is there any way i can turn it into a drive?
well this is the last effort, you download a windows 10 iso and use rufus to burn the iso to flashdrive, make sure it is set to GPT Partition and UEFI - Non CSM in the rufus settings, then start. then plug it in the top rear motherboard, go to bios, disable the sata controller or unplug the sata drives when you shut down the pc (make sure no sata drive is detected in pc, just m.2), disable all csm support, set the boot into UEFI only no legacy support, fast boot off, and boot drive into UEFI:Usb Name, when you're about to install the windows, choose custom instead of express, and see if your nvme drive is there. If it's there then it could be detected only when UEFI only is ON, no CSM options enabled.

TL;DR: Make bootable drive using rufus, set on gpt and uefi (non-csm), set the bios to UEFI only, no legacy, and boot priority to UEFI:Flashdrive name. see in the windows installation if the nvme is detected or not.

Anyways you're on bios F9 right now aren't ya? still using the modded bios right? if you have the time and discord we could talk about this :tearsofjoy:
 
Last edited:
Sep 21, 2021
12
2
15
0
well this is the last effort, you download a windows 10 iso and use rufus to burn the iso to flashdrive, make sure it is set to GPT Partition and UEFI - Non CSM in the rufus settings, then start. then plug it in the top rear motherboard, go to bios, disable the sata controller or unplug the sata drives when you shut down the pc (make sure no sata drive is detected in pc, just m.2), disable all csm support, set the boot into UEFI only no legacy support, fast boot off, and boot drive into UEFI:Usb Name, when you're about to install the windows, choose custom instead of express, and see if your nvme drive is there. If it's there then it could be detected only when UEFI only is ON, no CSM options enabled.

TL;DR: Make bootable drive using rufus, set on gpt and uefi (non-csm), set the bios to UEFI only, no legacy, and boot priority to UEFI:Flashdrive name. see in the windows installation if the nvme is detected or not.

Anyways you're on bios F9 right now aren't ya? still using the modded bios right? if you have the time and discord we could talk about this :tearsofjoy:
YESSS bro please if you can
 
Sep 21, 2021
12
2
15
0
well this is the last effort, you download a windows 10 iso and use rufus to burn the iso to flashdrive, make sure it is set to GPT Partition and UEFI - Non CSM in the rufus settings, then start. then plug it in the top rear motherboard, go to bios, disable the sata controller or unplug the sata drives when you shut down the pc (make sure no sata drive is detected in pc, just m.2), disable all csm support, set the boot into UEFI only no legacy support, fast boot off, and boot drive into UEFI:Usb Name, when you're about to install the windows, choose custom instead of express, and see if your nvme drive is there. If it's there then it could be detected only when UEFI only is ON, no CSM options enabled.

TL;DR: Make bootable drive using rufus, set on gpt and uefi (non-csm), set the bios to UEFI only, no legacy, and boot priority to UEFI:Flashdrive name. see in the windows installation if the nvme is detected or not.

Anyways you're on bios F9 right now aren't ya? still using the modded bios right? if you have the time and discord we could talk about this :tearsofjoy:
my discord is Superior#9717 :)
 

ASK THE COMMUNITY