Question Nvme ssd trouble

derek nagorcka

Distinguished
Oct 13, 2013
39
0
18,540
1
Hi
I recently upgraded the nvme ssd in my dads new HP laptop, after which I thought Id use the old 256gb nvme ssd in my desktop for a bit of extra space.
Weird thing is my pc simply does not see it not in windows or the bios, any ideas? Could it be some sort of lock HP have put on their drive? His laptop works fine with its new drive.

My pc has a Gigabyte Aorus master b550 with a 5950x, I have another 256gb nvme ssd in the top slot (the board has 3 m.2 slots), two sata ssd drives and one hdd in the sata ports.
Any help much appriciated
cheers
 
Hi
I recently upgraded the nvme ssd in my dads new HP laptop, after which I thought Id use the old 256gb nvme ssd in my desktop for a bit of extra space.
Weird thing is my pc simply does not see it not in windows or the bios, any ideas? Could it be some sort of lock HP have put on their drive? His laptop works fine with its new drive.

My pc has a Gigabyte Aorus master b550 with a 5950x, I have another 256gb nvme ssd in the top slot (the board has 3 m.2 slots), two sata ssd drives and one hdd in the sata ports.
Any help much appriciated
cheers
tried to place the ssd on the first slot and see if it detected?
 

derek nagorcka

Distinguished
Oct 13, 2013
39
0
18,540
1
Thanks for reply I haven't tried using the first slot because my system drive is in there, but I guess it would be good to try.

Feel like it might be a last resort or maybe I could try it with Linux on a usb or something.
 

derek nagorcka

Distinguished
Oct 13, 2013
39
0
18,540
1
I'll have a look at the name but I'm 99% sure it's nvme, it was advertised as one of the laptop. Also the ssd I replaced it with (in the laptop) was an nvme drive which worked fine. Anyway I'll check and come back
 

derek nagorcka

Distinguished
Oct 13, 2013
39
0
18,540
1
Yes - NVME. It's Samsung PM991 256GB model.

It's not properly inserted in the M.2 slot. Gold contacts should not be visible, if it was properly inserted.

Watch some videos, how to properly install M.2 drive.

View: https://www.youtube.com/watch?v=j8V5VVDW2-Y
Well spotted really thought you had it, but after re-seating a couple times (making sure the gold pins were not visible ) no change!
Pc does not detect it, nothing in BIOS, nothing in windows.

Might have to admit defeat on this one, maybe its just a dead drive?
 

derek nagorcka

Distinguished
Oct 13, 2013
39
0
18,540
1
OK so after my last post I open file explorer and drive H has appeared with a blue ? over the icon, I cant open it and it doesn't come up in the windows partition editor or in Paragon partition manager or even in the BIOS.
?????:mad:
Ideas?
Drive icon
 

derek nagorcka

Distinguished
Oct 13, 2013
39
0
18,540
1
Can you show, how the drive looks now?
Previously it looked, like you inserted behind metallic clip for M.2 heatsink (not in the actual M.2 slot).
(please use imgur.com instead)

Also show screenshot from Disk Management.
Heres a pic of the drive its definitely in the slot and as far in as it will go . I realise you can still just see the pins but it doesn't go in any further.
Screenshot of Disk Management
Thanks for the help much appreciated
 

derek nagorcka

Distinguished
Oct 13, 2013
39
0
18,540
1
Yes, it does, exactly as explained in the video, which is how I originally had it installed I just hadn't pushed it in properly. Might be worth trying another slot I guess, have to pull out my gpu which is a pain.
 

derek nagorcka

Distinguished
Oct 13, 2013
39
0
18,540
1
In case anyones interested I have solved my ssd issue, after installing latest BIOS (f14) it works! My last Bios update was march 2021 this was released on 1st oct.
I guess it could be a setting in the Bios that reset with the update but I have another nvme ssd which was working fine,
or maybe it was some newer/different drive type they needed to add support for, whatever it works👍
 

ASK THE COMMUNITY

TRENDING THREADS