Question NVMes' stuck at PCIe 3.0 x1 after RAID0

May 31, 2021
3
0
10
0
Hi everyone!

Straight to the point:
I've bought 2 Samsung Evo Plus NVMes, plugged them into the DIMM 2 slot, and made RAID 0 in Asus ROG apex Maximus 12 from them. (Please, don't ask me why the hell I did that; my regrets are endless).

So what did exactly happen? Before all that, one Samsung showed around 3,5 gb/s speed, in RAID 0 two of them showed around 1,7, when I realized a mistake I did, I have deleted RAID 0, reinstalled widows, but the speed of single Samsung NVMe became 0,8 gb/s.

So then I have started trying to fix this by changing various settings in UEFI, like changing auto mode to PCIe, changing the speed from auto to GEN 3.0, disabling SATA, reinstalling Windows all the time, etc.

Nothing helped. Tried to do Samsung magician secure erase (which is also I think rather useless), but the PC is not booting from the flash drive (tried 2 flash drives).

I took 1 NVMe out and inserted it into my old motherboard, and in Crystaldiskinfo it showed that it is working at PCIe 3.0 x4| PCIe 3.0 x4 (current mode|possible mode), while doing the same on the APEX MB Crystaldisk shows PCIe 3.0 x1| PCIe 3.0 x4, and, obviously, the speed was SATA-like: 0,8 gb/s.

So the last thing that I did was to take out the DIMM 2 with the NVMe's, left the PC and MB without power for around 15 min, then I turned it on, updated UEFI with a CAP file, found on the ASUS official APEX MAXIMUS XII webpage, then inserted DIMM 2 back, and ... no result.

Looks like my problem has something close to that, but not really I think:

Actually, I am kinda clueless about what to do next to bring the speed back again. I have sent that issue to ASUS tech support and currently waiting for their response. But I hope that someone here might know how to fix that. Thank everyone for any help and attention.

Processor: Intel i5 10600KF
Video Card: ASUS TUF Gaming GeForce RTX 3070
Motherboard: ASUS ROG MAXIMUS XII APEX, LGA 120
Memory: G.SKILL Trident Z RGB F4-3200C14D-32GTZR
New SSD: Samsung 970 Evo PLUS 500 gb NVMe
PCIe Adapter:

1 x ROG DIMM.2 Module supports 2 M.2 Socket 3, with M key, type 2242/2260/2280/22110 storage devices support (SATA & PCI-E 3.0 x 4 mode)*1
 

ASK THE COMMUNITY