[SOLVED] OBS makes game very choppy

laskeyperse

Reputable
Oct 22, 2014
14
0
4,510
0
Ok, fresh first ever install of OBS and streamlabs softwares.

I have no problem in-game until i open either of those programs. Before i go live with gameplay on OBS window, game is very sluggish and choppy. No impact on framerates tho. Same stable 120fps with or without OBS but on my main screen it looks like i had 20fps, counter still clocking that same 120fps.
With default settings and modified settings there is no difference. Also yes, tried separately, not at he same time.

Streaming with shadowplay there is 0 impact on gameplay.

So the question is which parts below i need to upgrade to have no impact on gameplay?
And why is OBS so heavy?

8600k
Strix 1080ti
16gb DDR4 Ripjaw
 
What encoder settings are you using in OBS? If you use nvenc it should have the same performance as shadowplay because both use the GPU for the work.
If you use x264 then it uses your CPU and it depends on your game if it will behave or not,since you still get the same 120FPS it's not a matter of CPU power so upgrading will not help,it's probably a problem with the game did you try other games?
 

laskeyperse

Reputable
Oct 22, 2014
14
0
4,510
0
Tried x264 and NVENC with no difference. I will try another game to see that makes difference.

E: in Forza Motorsport 7, CSGO and BFV same effect. That game was Forza Horizon 4 what i originally wanted to stream.

E2:
Capped to 60fps from game and no there is no problem at all. Weird.
 

laskeyperse

Reputable
Oct 22, 2014
14
0
4,510
0
I could have just edited my previous post but i wanted to shed some new light to it and maybe new eyes and minds...

So with encoders x264 or NVENC i don't see any difference, except that with x264 game doesn't automatically cap fps to 60. Vsync drops fps to 60 right when i launch SLOBS, my 144hz monitor is set to 120hz. I close that program, in game fps goes back up to 120.
If i manually cap fps to 60 from in game settings there is no rubberbanding, if i don't cap it it just stretches and bounces around.

All this happens before i click GO LIVE button, just by having SLOBS open.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts