• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

[SOLVED] OBS streaming settings???

Flame1

Commendable
Aug 8, 2017
70
1
1,545
3
So I installed OBS for the first time ever and my friends immediately said that the first thing I should do is change the encoder from X264 to NVENC (new), so I did that and I've set the bitrate to 8000, the stream was pixelated so I decided to up that to 10k which made it less pixelated but the lag was still there so I went all the way to 15k and the stream was not pixelated any more but it was still lagging/skipping frames.
I want to target 1440p60fps for my streams.
Im a complete Noob to streaming with OBS, before that I used the shadowplay in-built broadcasting and using that made my streams look way better with barelly any pixelation and no lag at 1440p 60fps. My internet upload speed is 18Mbs and I am streaming to YouTube however I might switch platforms at some point.

Should I try using X264?
If so which cpu usage preset and bitrate should I use?

Thanks in advance!
 

Newtonius

Upstanding
Sep 25, 2019
498
94
340
39
So I've done exactly what you said, installed streamlabs obs, selected streaming service as youtube and set bitrate to 15k and set the encoder to NVENC new and literally after the first minute of the stream I got a notification saying that I skipped 20% of the frames. I tried lowering the resolution to 1080p and lowering the bitrate, but it seems like no matter what I try I always skip a lot of frames with by using OBS.
Here are my settings, try to set it as the same and test it out. I use it on mIxer and twitch with no issues and I also have only 1.5Mbps upload.

Oh and if you're putting your OBS window on another monitor with less than 144Hz, I would switch the main OBS display to the store window or somewhere else that's not playing the video from your display capture. Playing a video on another monitor with a lower refresh rate will drop your main screen's refresh rate and ultimately the streaming fps as well. So don't have any videos playing on another monitor with lower refresh rates.







 
Last edited:
Reactions: Flame1

Newtonius

Upstanding
Sep 25, 2019
498
94
340
39
For 1440p 60FPS you need to set the bitrate to anywhere between 9,000-18,000. So you should have no problem setting it to 18k bitrate.

You have a 3900x, you should also set the encoder to utilize as much of the CPU as possible. And make sure that when you logged into OBs that you chose YOUTUBE as the service, I migrated from twitch to mixer without changing the service and that was a major source of my lag.
 
Reactions: Flame1

Flame1

Commendable
Aug 8, 2017
70
1
1,545
3
For 1440p 60FPS you need to set the bitrate to anywhere between 9,000-18,000. So you should have no problem setting it to 18k bitrate.

You have a 3900x, you should also set the encoder to utilize as much of the CPU as possible. And make sure that when you logged into OBs that you chose YOUTUBE as the service, I migrated from twitch to mixer without changing the service and that was a major source of my lag.
I tried setting it to x264 fast, medium, slow and slower all of which caused skipped frames. Also tried with the bitrate at 15k,18k and 20k, was still getting skipped frames so then i started reducing resolution and bitrate and even down at 720p with 6k bitrate i was still getting skipped frames. Then I ran the stream with the Nvidia shadowplay in-built broadcasting feature and the stream ran perfectly at 1440p60fps. Im lost for words with obs....

By skipped frames i dont mean like 1 or 2 after an hour, it was to the point where the stream looked like a slideshow at certain moments.
 

Newtonius

Upstanding
Sep 25, 2019
498
94
340
39
I tried setting it to x264 fast, medium, slow and slower all of which caused skipped frames. Also tried with the bitrate at 15k,18k and 20k, was still getting skipped frames so then i started reducing resolution and bitrate and even down at 720p with 6k bitrate i was still getting skipped frames. Then I ran the stream with the Nvidia shadowplay in-built broadcasting feature and the stream ran perfectly at 1440p60fps. Im lost for words with obs....

By skipped frames i dont mean like 1 or 2 after an hour, it was to the point where the stream looked like a slideshow at certain moments.
Firstly which OBS are you using? I would recommend using streamlabs OBS.

Once you install that, log into streamlabs OBS on the bottom left and you HAVE to make sure to choose the correct streaming service or you will get that error with skipping frames.

Next go into settings then "output" and set the encoder into nvenc (new). Don't worry about what I said before. Set the bitrate to 15k at first.

leave everything else alone and go into the "video" and set it up for 1440p 144FPS.

The most important part really is making sure you select the correct streaming service at login.
Try a test stream and keep fiddling around with streamlabs.
 
Reactions: Flame1

Flame1

Commendable
Aug 8, 2017
70
1
1,545
3
Firstly which OBS are you using? I would recommend using streamlabs OBS.

Once you install that, log into streamlabs OBS on the bottom left and you HAVE to make sure to choose the correct streaming service or you will get that error with skipping frames.

Next go into settings then "output" and set the encoder into nvenc (new). Don't worry about what I said before. Set the bitrate to 15k at first.

leave everything else alone and go into the "video" and set it up for 1440p 144FPS.

The most important part really is making sure you select the correct streaming service at login.
Try a test stream and keep fiddling around with streamlabs.
So I've done exactly what you said, installed streamlabs obs, selected streaming service as youtube and set bitrate to 15k and set the encoder to NVENC new and literally after the first minute of the stream I got a notification saying that I skipped 20% of the frames. I tried lowering the resolution to 1080p and lowering the bitrate, but it seems like no matter what I try I always skip a lot of frames with by using OBS.
 

Newtonius

Upstanding
Sep 25, 2019
498
94
340
39
So I've done exactly what you said, installed streamlabs obs, selected streaming service as youtube and set bitrate to 15k and set the encoder to NVENC new and literally after the first minute of the stream I got a notification saying that I skipped 20% of the frames. I tried lowering the resolution to 1080p and lowering the bitrate, but it seems like no matter what I try I always skip a lot of frames with by using OBS.
Here are my settings, try to set it as the same and test it out. I use it on mIxer and twitch with no issues and I also have only 1.5Mbps upload.

Oh and if you're putting your OBS window on another monitor with less than 144Hz, I would switch the main OBS display to the store window or somewhere else that's not playing the video from your display capture. Playing a video on another monitor with a lower refresh rate will drop your main screen's refresh rate and ultimately the streaming fps as well. So don't have any videos playing on another monitor with lower refresh rates.







 
Last edited:
Reactions: Flame1

Flame1

Commendable
Aug 8, 2017
70
1
1,545
3
Here are my settings, try to set it as the same and test it out. I use it on mIxer and twitch with no issues and I also have only 1.5Mbps upload.

Oh and if you're putting your OBS window on another monitor with less than 144Hz, I would switch the main OBS display to the store window or somewhere else that's not playing the video from your display capture. Playing a video on another monitor with a lower refresh rate will drop your main screen's refresh rate and ultimately the streaming fps as well. So don't have any videos playing on another monitor with lower refresh rates.







I have managed to find the reason for the skipped frames. It turned out I was skipping frames because I was using the "Display capture" source and after I have added a new source called "game capture" and put the game I was playing into it, the issue completely disappeared and the streams are now smooth at 1440p60fps at 17k bitrate with NVENC (new). Now Im just debating whether I should leave it at that or change to X264 encoding. Thanks for taking your time again I really appreciate you trying to help!
 
Reactions: helper800

Newtonius

Upstanding
Sep 25, 2019
498
94
340
39
I have managed to find the reason for the skipped frames. It turned out I was skipping frames because I was using the "Display capture" source and after I have added a new source called "game capture" and put the game I was playing into it, the issue completely disappeared and the streams are now smooth at 1440p60fps at 17k bitrate with NVENC (new). Now Im just debating whether I should leave it at that or change to X264 encoding. Thanks for taking your time again I really appreciate you trying to help!
Odd, normally that shouldn't cause the issue but I guess it did, I only ever used display capture. But I guess the most recent update might've screwed that over. I haven't streamed recently so I wouldn't know, will have to test later today.

I would stick with NVENC new since it is better for dynamic compression when streaming. x264 eats away CPU performance which clearly has an affect on gameplay FPS, while NVENC uses the GPU and has little to no performance drop. It's much better on the RTX series as compared to your 1080Ti, but it should still hold up just fine. The best however is x265, but OBS doesn't support that for streaming. Yet.... x265 is a monster at compression and quality preservation.
 
Reactions: Flame1

ASK THE COMMUNITY

TRENDING THREADS