Question Office 365 ProPlus won't install

Aug 11, 2019
4
0
10
0
Hi. My Office won't install and instead gets stuck at "We're getting things ready" splash screen and I tried almost every solution I found on the internet.

I have an Office 365 Subscription that came with my University account, which is the one I used to download the installer for Office. I still used the suite before but not until the 31st of October, when suddenly one of the apps didn't work as expected and I attempted to fix it using Quick Repair, however, no luck. Which lead me to use Online Repair. But then, that took so long, so I had to force stop the process. Suddenly, all the Office files were gone and only the registry entries were left behind. So, I tried to re-install the suite but then it gets stuck at the splash screen as aforementioned.

Solutions used:
  • Full uninstall of the Office: which includes total removal of all traces of Office in Program Files, Program Data, and Registry Editor then Reinstallation
  • Installation through the Office Deployment Tool
  • Using Microsoft Support and Recovery Assistant (SARA)
  • System Restore (which in this case did not work as well as it states "0x8007045b Unexpected error occurred..." something like that... but the suite was included in the "To be restored apps" lists.)
...and all of these solutions only led to either an error or getting stuck at the splash screen for a very long time. I did try to install both x86 and x64 architecture versions but no luck. Resetting the laptop is my last resort, however, I do not want to reset the laptop as I will start again from scratch.

Any solutions? Thank you.


UPDATE: I installed Office 2016 and it worked perfectly. Attempted to install Office 365, still no luck.
 
Last edited:

Ralston18

Titan
Moderator
Laptop hardware specs? OS?

How full is the drive?

Do you know if any other students are having similar problems?

Have you contacted the University's IT support desk?

The registry editing may have made a simpler problem worse. Registry editing is only a last resort effort to be used only if you know and have verified that all backed up data is recoverable and readable.

Give "sfc /scannow" a try. May find and fix some related file problem(s).

https://www.lifewire.com/how-to-use-sfc-scannow-to-repair-windows-system-files-2626161

Do backup and verify all your documents beforehand.

Could be something else going on and anything you do may cause loss of data,
 

ASK THE COMMUNITY

TRENDING THREADS