Question Old access data base not working after upgrading to Windows 10

Feb 10, 2020
5
0
10
0
I'm not good with English so bear with me.

An old database of access stopped working after upgrading to Windows 10.
Its for work but I cannot reach the IT person for a while but I need to use the database.

I get a "run time error 2501" and something to do with OpenForm when I choose a certain input option, and sadly that's the most important one.

I tried access 2016, 2007, 2000. Nothing works.

Its not something wrong with the database it self, it works fine on my co-worker's laptop.

Any help is greatly appreciated.
 

gmagdna

Prominent
Jul 16, 2018
127
15
595
1
Another possibility - since you're able to successfully run the same report from a co-workers laptop, I assume using their ID, the error could point to an issue with Trusted Locations created by the Win 10 upgrade.
 
Feb 10, 2020
5
0
10
0
Try repair or reinstalling visual c ++ runtime or
Try saving file ( on another pc) in other access version then open it on your pc.
Tried reinstalling every visual c++ there is, doesn't work. Also, I don't have another PC with office installed at the moment. :(
 
Feb 10, 2020
5
0
10
0
Another possibility - since you're able to successfully run the same report from a co-workers laptop, I assume using their ID, the error could point to an issue with Trusted Locations created by the Win 10 upgrade.
Is there anyway I can run it on the laptop?
 

gmagdna

Prominent
Jul 16, 2018
127
15
595
1
Is there anyway I can run it on the laptop?
I'm not certain I'm right on the cause but you can try:

  1. Click the File tab.
  2. Click Options.
  3. Click Trust Center, and then click Trust Center Settings.
  4. Click Trusted Documents.
  5. Check "Allow documents on a network to be trusted"
Then select Trusted Locations (above Trusted Document) and add C:\



There aren't any pending Win Updates?
 
Last edited:
Reactions: MaxIsMighty
Feb 10, 2020
5
0
10
0
No windows updates pending. I set the location of the database and the database itself to trusted. I also tried opening it on my personal computer that has Office 2016, doesn't open. I thought the database was corrupted or something so I got a fresh copy, same problem. Becoming hopeless here :(
 
Feb 10, 2020
5
0
10
0
Solved! the database itself has a lot of things in arabic. Changing system's locale to arabic solved it. I appreciate you both for the help tho, truly.
 

ASK THE COMMUNITY

TRENDING THREADS