[SOLVED] Old games suddenly starts to lag on upgraded PC

BirdieBrain

Prominent
May 23, 2017
19
0
510
0
Hello,

I've recently had a problem with my computer. Recently, games have started to lag. It works fine in the beginning, but starts to lag a bit into the game. There's mainly two games in question; Batman Arkham City and Batman Arkham Knight (but other games as well). But here's the weird part: I played these two games when they came out (several years ago) and I played through them without any form of problems or lag. And that was on an older PC. Since then I've upgraded several parts, and I've cleaned the whole PC. That's why I thought it was strange that it starts to lag now that I have better parts. It's not just little stuttering either, it's full on lag. Not playable.

My specs:
OS: Windows 10 64-bit
Graphics card: ASUS GeForce GTX 1060 6GB Dual OC (upgraded from Sapphire Radeon 7770)
RAM: Kingston ValueR. DDR3 1333MHz 8GB
CPU: AMD FX-8350 Black Edition (upgraded from AM FX-4100)
PSU: Silver Power SP-SS500 500W (soon to be upgraded to 1000W, can't remember the brand)

I have tried:
- Restarting the game
- Reinstalling the game
- Restarting my PC
- Cleaned the entire PC
- Upgraded to a new cooler (Cooler Master MasterLiquid 240)
- Reformatted it back to original OS (not a total wipe)
- Cleaned the PC with Malwarebytes
- Checked for drivers (all up to date as of writing)

I would appreciate any answers, as this is very annoying. It doesn't happen to every game, that's why I think it's very strange.

Games it lags on:
- Batman Arkham City
- Batman Arkham Knight
- Minecraft
I haven't tested alot of games, but these three are the ones I know lag.

Thanks in advance! (Just a heads up, I'm not very good with PCs, so some things may be written wrong.)
 

ASK THE COMMUNITY

TRENDING THREADS