Question Onboard audio not working on MSI 970 Gaming?

Oct 2, 2020
2
0
10
0
I was setting up my old computer to get sold and was doing a fresh install of windows on a new hard drive (I had to reformat the drive). Now the on board audio doesn't seem to work. (USB speakers still work, but anything plugged into and audio jack does not) I have tried removing and reinstalling the latest Realtek audio drivers. In the bios, there is a page with an interactive display of the mother board. When I select the audio inputs, it says they are disconnected, was wondering if that may have anything to do with it. Other than that i'm lost.

Please let me know if you have an idea of a possible solution.

Thank you!
 

SteveRX4

Notable
BANNED
Sep 29, 2020
1,477
135
890
109
OK. Thanks. It's pretty old.

But it has ALC 1150 Realtek which should be still current and compatible with Windows 10.

Audio input would be from a microphone. Everything else would be output I think.

Do the speakers work - did they before and do they now?
 

Phillip Corcoran

Titan
Moderator
RX470 incorporates an audio chip for HDMI audio output.

When you installed the RX470, by default it also installs it's audio drivers if you chose Express Install, so HDMI audio becomes the default and the 3.5mm audio ports/Realtek audio device stop working.

This happenned to me and I fixed it by uninstalling the the RX470 drivers completely, then begin installation again but choose "Custom Install" which will allow you to deselect it's audio drivers before commencing with the installation.
 

ASK THE COMMUNITY