Question One Monitor keeps turning on and off repeatedly, only logo shows up.

SirTennant

Commendable
Apr 7, 2020
9
1
1,515
0
Hello, I have this issue, one of my monitors suddenly started turning off and on repeatedly while I was playing a game. It turned off, turned on for about 2 seconds (it showed the display), but then turned off again - and this happened on repeat. When I turned off the monitor manually and tried to turn it on again, no screen appeared again except the ASUS logo. So right now, I turn on the monitor, the ASUS logo appears, the monitor turns off, it turns on - the logo appears, it turns off - this on repeat.

I tried securing both the power cable and the cable leading into the GPU and also tried unplugging and plugging back, but neither helped. I also tried updating the graphic drivers, also didn't help. I also, of course, tried restarting the computer.

The other monitor is plugged into the motherboard and is working fine, the working monitor is using DVI while the non-working one is using HDMI, at least that's what it says on the port on the monitor. However, the HDMI cable coming from the monitor doesn't fit into any other port in the GPU so I couldn't test other ports and I didn't want to test plugging it into the motherboard, because I didn't want to unplug my working monitor but I suppose it wouldn't work anyway since my working monitor has a DVI cable.

At least to me, this is shaping up to be some kind of GPU problem or I don't know since it's only the monitor that's plugged into the GPU that's having issues, and at least the monitor logo ASUS shows up so it has to be working to some degree. However, other than that the GPU is working fine, it's not overheating, games aren't lagging and the GPU is getting detected in dxdiag. The graphic driver update also went smoothly. Another issue I thought might be happening was that the monitor might've been overheating so I just turned it off and let it be that way for like 1,5 hours but even after that time, it was still doing the same thing.

One thing I can say is that the working monitor is from 2016, so pretty old and the other that's currently not working is even older, but can't tell you how old exactly.
Also, my motherboard is brand new because my old one broke like 2 weeks ago.

Not sure if my specs are necessary but I'll send it your way anyway
The currently working Monitor is: ASUS VP228
The currently non-working Monitor is: ASUS VX228
PSU: Corsair CX650M
OS: Windows 10 64-bit
Motherboard: MSI B450 Tomahawk MAX
CPU: AMD Ryzen 5 2600X
GPU: Gainward GeForce GTX 1060, 6GB
RAM: 32GB (4x8 3200MHz) (but actually running at 2400MHz right now)

Thanks in advance for any help!
 

SirTennant

Commendable
Apr 7, 2020
9
1
1,515
0
I just solved it by getting a new monitor, this new one works in the exact same port even with the old cable, so ye it was the monitor that died. Thanks for the advice anyway!
 
Reactions: DRagor
Jul 2, 2022
1
0
10
0
I'm having exactly the same issue, started approx. a week ago. While gaming one monitor turns off and after a few seconds back on again. Doesn't matter if I'm playing Spelunky or PUBG....:unsure:
 

ASK THE COMMUNITY

TRENDING THREADS