Question One of two GPU DisplayPorts is being "limited"

DarkAvenger34

Commendable
Oct 2, 2016
3
0
1,510
0
So this issue requires some backstory. My monitor setup for a year or two has been a 1080p display (Asus VX238H) and a 4k display (Asus PB287) using an HDMI and DisplayPort respectively. Both have worked without a hitch until about a couple months ago when my PB287 remained black after starting up my system. After restarting, the issue persisted so I decided to try switching to my second DP Port on my GPU. This time, my 4k display turned on as expected and I haven't had an issue since.

However, I recently decided to upgrade my 1080p display to a 1440p 165Hz display (Dell S2417DG) and this requires me to use both DisplayPorts on my gpu. After spending many hours trying to fix this issue I have found that while both displayports do in fact work, the one that was having the original issues seems to be getting "limited". When I run my PB287 on the working port it has no problems displaying at 4K 60Hz in RGB color format at full dynamic range, but when I try running the same monitor on the other port with the same cable (although I've tried other cables) it can only display either 4K 60Hz in the YCbCr422 color range or 4K 30Hz in the RGB color format at full dynamic range. If I set the PB287 at 4K 60Hz AND RGB color format the monitor will go black and is unable to display anything, although both NVIDIA Control Panel and Windows still detect the monitor.

So far, I've tried reinstalling display drivers, removing both monitors from devices and reinstalling them, making sure windows is fully updated, power cycled both monitors, reconnecting the GPU power connector, swapping cords, etc. I haven't been able to find anyone else with an issue quite like this one.

Thanks for reading!

Specs:
i5-4690k @ 4.0 GHz
GTX 1070
MSI Z97S SLI Krait Edition
G.Skill Ripjaws X Series 8 GB (2 x 4 GB) DDR3-1866
Corsair CX 430 W 80+ Bronze
Displays:
Asus VX238H
Asus PB287Q
Dell S2417DG
 

ASK THE COMMUNITY

TRENDING THREADS