Question One of two monitors all of a sudden not displaying (other than black screen) despite no issue with graphics outputs.

Aug 23, 2020
2
0
10
0
Earlier today everything was working fine, turned off my computer for a few hours and now my main monitor is a black screen (has input, it's just blank). I have one monitor HDMI'd into my GPU and the other into onboard graphics as I have for years. My current main monitor is relatively new but has been working fine up until the latter half of today. At first I assumed the issue was my GPU (as that's what the main monitor is plugged into) so tried some troubleshooting there (reseating GPU, reinstalling drivers, etc) before simply trying swapping the HDMI cables so that my second monitor was plugged into the GPU output and the main monitor into the mobo output and the GPU is outputting no problem to my second monitor. I know the obvious answer here is an issue with the main monitor itself, but why would I still get input (but black screen) and my PC have no issues detecting the monitor? I'm hoping there are solutions other than "the monitor is just now somehow dead but only kinda dead". Any help would be appreciated. If it helps the monitor is a Westinghouse WC27PX9019. I have tried unplugging power to the monitor as well as have tried both HDMI ports on the monitor itself.
 

Ralston18

Titan
Moderator
The computer is likely just using some pin combination that detects the presence of a monitor but does not know/detect that some component within the monitor is not/may not be functioning with the end result being the black screen.

Check that the monitor's menus are correctly configured for the port being used.

Try reinstalling the applicable GPU and monitor drivers.

Then try the main (non-working) monitor on another known working computer.

Try another known working monitor on your computer in place of the main monitor while your normal second monitor is in place.

Determine if the problem follows the monitor or stays with the computer.
 
Aug 23, 2020
2
0
10
0
My original troubleshooting involved reinstalling drivers as well as connecting my secondary monitor to both the GPU and mobo outputs, secondary monitor worked with both, drivers didn't fix anything.

I hadn't thought about it originally but today I hooked up the monitor to my laptop, still just a black screen. Seems the monitor is just dead. Well, alive but not working as intended.

Unfortunately don't have a third monitor to further test other monitor configurations but I think I'm convinced the monitor is just borked. I appreciate your response.
 

ASK THE COMMUNITY

TRENDING THREADS