"One or more network protocols missing..."

Ngale

Reputable
Jun 13, 2014
64
0
4,640
1
I have a Lenovo Z575 laptop w/ Windows 10.

I recently updated to Windows 10 a couple months ago and everything was fine up until recently. I've been having this issue the past couple of days where I try to load up a webpage, it states that connection has timed out, so I use the Troubleshoot Problems option for my wifi, and it gives me the statement "One or more network protocols are missing". I used the "netsh int ip reset" command in the Command Prompt, and that seemed to work at first, but yesterday it happened again, only this time, it seems to pick and choose what pages load.

Can someone give me any advice as to what else I can do? Thanks!
 

CN Shana

Reputable
Jun 10, 2015
109
0
4,710
7
you can run berkleys net analyzer to diagnose issues and maybe this will help/explain your problems,

goodluck

http://netalyzr.icsi.berkeley.edu/
 

Strid3r_2442

Reputable
Jul 13, 2015
13
0
4,520
2
Hello Ngale,

If you haven't fixed this then I may be able to help.

Most forums and even Microsoft support will say that this is a problem with Windows System files but sometimes it's not which is why 'sfc /scannow' won't show anything. It is actually a problem with the protocols but no one thinks that was as no one uninstalls them manually before this error appears.

Go to Settings -> Network & Internet -> Ethernet (I don't use Wi-Fi so if Wi-Fi is an option, try it) -> Change adapter options -> Right-click the one you are having issues with -> Properties -> Install... -> Protocol -> Install what is there (For me I had one called 'Reliable Multicast Protocol' so I installed that. I haven't found this solution elsewhere so I don't know what it'll be for you.) -> You're done!

If this worked for you, please let me know and if there was a different protocol then please inform me with it's name. Cheers!
 

Ngale

Reputable
Jun 13, 2014
64
0
4,640
1


Just tried it. I had to install the same thing you said. I'll wait to see if that fixes it. Thanks!
 

Strid3r_2442

Reputable
Jul 13, 2015
13
0
4,520
2


Awesome, tell me if it has fixed it and if it has, don't forget to select my answer as your solution as it helps out others find a solution and helps me out!

Have a great day!
 

bschmitt06

Reputable
Jan 27, 2016
1
0
4,510
0


This solution worked for me. Cheers!
 

Ngale

Reputable
Jun 13, 2014
64
0
4,640
1


It does seem to have worked for me too! Thank you!
 

Sharmil_1

Reputable
Feb 11, 2016
1
0
4,510
0


Worked for me!
 

NorthCat

Commendable
Mar 4, 2016
1
0
1,510
0
Gents! (And ladies as well)

May be my experience will be helpful to somebody

Hardware: Toshiba Satellite P55W-C5200X - Problem Solved by turning off BlueTooth and drivers re-installation

Details:
All of sudden started to loose Wi-fi connection, network troubleshooter showed this ominous message.
Tried everything mentioned above,
1. fall back to original restore point
2. netsh winsock reset
3. netsh int ip reset c:\resetLocsk.txt (along with changes to registry)
4. re-installed network drivers (from manufacturer site) - several times in different combinations)
No luck. Sometimes Wi-fi appeared in above 3-5 minutes after reboot, sometimes not.

After three days of heavy suffering - decided to turn off all but vitally required. Deleted all stuff from under Network Adapters (Device Manager), turned off BlueTooth<<! (in Settings) and re-installed one more time network drivers (tcg0006400h). After one more time reboot notebook no longer looses Wi-fi connectivity. (knock the wood!)
 

Puterman50

Commendable
Mar 8, 2016
4
0
1,510
0


I used this fix on my computer Windows 10 and the missing protocol was as stated above Reliable Multicast and after installing, it worked. Any idea why it would drop that protocol and have to have it reinstalled?
 

Lori_723

Commendable
Mar 13, 2016
1
0
1,510
0
Unfortunately, this one did NOT work for me any better than all of the other ones that have been posted around the internet, all of which I have tried. Going on about 10 weeks for me... NOT a happy camper....
 

Puterman50

Commendable
Mar 8, 2016
4
0
1,510
0
right click on your network wifi in the bottom right hand and go to open network and sharing center, on the left the box that says change adapter settings, left click. On the network connections, right click on the wireless connection and left click on properties, Left click install, then left click protocols and you should see reliable multicast protocol under that header, highlight and click add. Once added, make sure you check the box and ok out of everything and close and reopen Edge or IE whatever you're using. Should be fixed. Email putermanto65@gmail.com if still an issue
 

rhinmass

Reputable
Nov 4, 2014
2
0
4,510
0
At first this solution appeared to work, but after a few minutes, I began to have connectivity issues again. I then went back into the Network Adapters (Windows 10) Network Settings, Change adapter options; Right-click Wi-Fi 2; Properties; Configure... ; Driver; Update Driver ....
It found and installed a new driver. I then restarted my computer. So far seems to be working great.
...Spoke too soon. Internet still very slow and it keeps dropping.

Update (the next day)
This is what finally fixed it.
I did a system restore to a point a few days back. (I"m not sure if this was necessary because...)
After the system restore and reboot it was still not any better. In fact the Wi-Fi adapter was now missing.
I then went to my Network drivers and Uninstalled the Wi-Fi driver.
Rebooted PC.
Everything working great now.

Udate (a few days later)
The connectivity problems started happening again even after the driver update. I finally deduced it was intermittent interference with bluetooth which I had enabled a few days before (when this all started). When I disabled bluetooth, everything worked fine. Turns out both bluetooth and wifi are using the same 2.4 ghz band. Since my Intel Centrino Wireless-N 2230 is not capable of using 5ghz band I thought I would not be able to operated both simultaneously. However someone pointed out to me that there are actually 11 channels in the 2.4ghz band. My router was set to use channel "automatic". I changed it to 11 and gave it a try. No more interference.
 

blift1

Commendable
Mar 28, 2016
3
0
1,510
0
SOLVED!!!!! Tried every suggestion on the internet. Nothing worked. Comcast is dealing with an "end of useful life" issue with some of their modems. As soon as I replaced my modem with their new one, the problem was resolved.

 

Puterman50

Commendable
Mar 8, 2016
4
0
1,510
0


 

Cornish

Commendable
May 9, 2016
1
0
1,510
0


 

Luke_46

Commendable
May 9, 2016
1
0
1,510
0
I had to create an account to post this. None of the solutions on here worked for me. So what i did was just uninstall the problem one and it worked again.
 

Sammeh_1

Commendable
May 17, 2016
1
0
1,510
0
Hi, I actually experienced the same problem when i was trying to download torrents from kat.cr. I have thankfully found a fix. Here's a link to my reference. http://appuals.com/best-fix-one-or-more-network-protocols-are-missing/. You can try all methods but the one that fixed mine is method 2. I hope this helps you
 

charlie12

Reputable
Feb 8, 2015
47
0
4,530
0


Im having this problem after updating windows 10, tried all methods i can find that people claimed to have fixed the problem but hasn't fixed mine. I tried this method and as i was installing 'reliable multicast protocol' it stopped responding and closed down the box for me. When I then tried to do it again there was nothing there anymore to install. can you help me out please nothing seems to be working for me?
 

Asi_1_

Commendable
May 29, 2016
1
0
1,510
0


Omg! You are a lifesaver. I've been having trouble connecting wirelessly to my internet for a few days now. It works now! Thanks so much
 

ASK THE COMMUNITY

TRENDING THREADS