Info One possible solution for err_ssl_bad_record_mac_alert error in Windows 10

Gabe D

Reputable
Mar 29, 2017
6
0
4,520
1
This isn't so much of a question as it is a solution to an issue I've had the last couple days which I thought I'd post here to save someone else some frustration in case they also happen to experience this. I believe this will only apply to those who use a Killer Wireless brand WiFi card though so if you are receiving this error and have another card installed you may need to check elsewhere for a solution (if you are not sure which wireless card you have installed just click in the Windows search bar in the lower left corner of windows, type Device Manager, hit enter, then click on the arrow next to "Network Adapters" and it should say which brand card you are using somewhere in the top few options).

Basically, an update or whatever caused the issue resulted in the following:

  • " err_ssl_bad_record_mac_alert " page comes up frequently when trying to connect to a website (I tried both Chrome and Edge)
  • Some sites will connect though this error or another error will come up when you try to log in to the site or download something
  • Some sites will load though you cannot click on anything in the window
  • A few random sites will still load and let you log in (Youtube for one)
  • Receive an error when trying to run Windows Update
  • Can no longer log into Windows 10 with a Pin (if you have one set up)
Regrettably I am not able to remember some of the other scenarios or specific errors which occurred as a result of this issue so that I could reference them here though the err_ssl... error and inability to connect to a website were the most frequent.

After trying nearly every solution I could find or think of I ended up doing the following:

  • Run a variation of a "Clean Boot" by hitting the Windows key and R and then typing in msconfig and hitting enter
  • Change the selection from "Normal startup" to "Selective startup" and the three boxes below that option are ok to have selected
  • Go to the "Services" tab and scroll down until you find "Killer Network Service" (you can also select "Hide All Microsoft Services" to make it easier to find if you want)
  • Deselect the "Killer Network Service" option, click "Apply" then "OK" then reboot when prompted and if you were having the same issue as me this should do the trick
There could be some other variations on the Clean Boot which you can try running through if this does not work, such as deselecting all services other than Microsoft Services and disabling all startup items and then rebooting to see if that works and then you can narrow it down from there by enabling items a few at a time and then rebooting each time, though if your issue is the same as mine all you will need to change is startup type and Killer Network Service option to get it solved.

Good luck!
 

ASK THE COMMUNITY

TRENDING THREADS