• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Ongoing Problems with USB WiFi Adapter, esp when other USBs plugged in

lee1127

Distinguished
Jun 21, 2013
22
0
18,510
0
Hey guys,

I have this TPLink WiFi adapter which I bought to replace what I thought was a faulty adapter from a noname brand a year ago. Turns out the problem persisted. Even after I recently upgraded my setup I still have the problem.

X570 Aorus Elite,
Ryzen 7 3800X,
2x8GB Gskill Ripjaws at 3200MHz,
GTX1060 6GB),

Basically, whenever I launch a full screen game, plug a USB flash drive into the back panel, or (more recently) try to launch VR headset through Oculus, the adapter crashes somehow, or it says I'm connected but gives me a DNS lookup failure (all the while my phone WiFi works on the same home network). Sometimes plugging the USB adapter in causes BSODs ("Page Fault In Nonpaged Area" and "System Thread Exception Not Handled").

Have tried uninstalling the device and drivers, have tried installing the official TPlink driver through their software, have set Windows not to automatically update drivers a long time ago...nothing has worked. Any help would be most welcome!
 
Last edited by a moderator:

ASK THE COMMUNITY

TRENDING THREADS