[SOLVED] optimize my BIOS so that it takes less time to boot ?

ismail783

Distinguished
Sep 17, 2008
22
0
18,510
0
I am using Asus Prime H370-Plus ATX LGA1151.

My system has been booting slowly so I ran some diagnoses.

% systemd-analyze
Startup finished in 22.344s (firmware) + 4.910s (loader) + 3.251s (kernel) + 1.099s (userspace) = 31.605s

So, the slow boot time is probably due to the UEFI. How can I optimize my bios so that it takes less time to boot?
 
If you have a device adapter and no device is detected, there will be a time out before the start can proceed. Disable such adapters.

In the bios, there might be a ram check that is started, either by default or by design.

Fast boot will load a file image of windows which takes less time than cold loading individual components.

Best of all, don't boot normally.
Use sleep to ram(no hibernate instead
 
Reactions: ismail783

ismail783

Distinguished
Sep 17, 2008
22
0
18,510
0
I am extremely sorry for the delay.

what your full system spec? include all Accessories
Bash:
% inxi -F
System:    Host: ismail-i5 Kernel: 5.4.0-56-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME H370-PLUS v: Rev 1.xx serial: <superuser/root required>
           UEFI: American Megatrends v: 2301 date: 07/10/2020
CPU:       Topology: 6-Core model: Intel Core i5-8600K bits: 64 type: MCP L2 cache: 9216 KiB
           Speed: 2387 MHz min/max: 800/4300 MHz Core speeds (MHz): 1: 2723 2: 2401 3: 2149 4: 2608 5: 2235 6: 2494
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
           resolution: 1920x1080~60Hz, 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.8
Audio:     Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
           Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
           Sound Server: ALSA v: k5.4.0-56-generic
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: 18:31:bf:b5:e6:5b
Drives:    Local Storage: total: 7.50 TiB used: 4.55 TiB (60.6%)
           ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB
           ID-2: /dev/sdb vendor: Western Digital model: WD40PURX-64N96Y0 size: 3.64 TiB
           ID-3: /dev/sdc vendor: Western Digital model: WD40EFRX-68WT0N0 size: 3.64 TiB
Partition: ID-1: / size: 227.74 GiB used: 38.87 GiB (17.1%) fs: ext4 dev: /dev/sda2
Sensors:   System Temperatures: cpu: 27.8 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 260 Uptime: 1d 9h 29m Memory: 31.03 GiB used: 9.07 GiB (29.2%) Shell: zsh inxi: 3.0.38
Other than this I have a Canon iP2700-series printer.

Bash:
% lpstat -p
printer iP2700-series disabled since Mon 30 Nov 2020 09:10:51 PM +06 -
    Unplugged or turned off
 
Last edited:
If you have a device adapter and no device is detected, there will be a time out before the start can proceed. Disable such adapters.

In the bios, there might be a ram check that is started, either by default or by design.

Fast boot will load a file image of windows which takes less time than cold loading individual components.

Best of all, don't boot normally.
Use sleep to ram(no hibernate instead
 
Reactions: ismail783

ASK THE COMMUNITY

TRENDING THREADS