• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

Question Origin EON17-X + I9 9900k = No Boot?!

SimpleRock8

Prominent
Jan 27, 2020
3
0
510
0
Hello,

I recently was able to get an upgradable origin EON17-X which has an I7-7700k + GTX 1080. I decided to try to upgrade the cpu, I installed an I9 9900k I recently purchased. When I attempted to boot up the labtop, it wouldn’t even start. The power light would turn on for a split second then just shut off. I reinstalled the I7 cpu and it works fine. I’m confused why it wasn’t working because I know the labtop can have up to a 9900k because it’s an LGA 1151 socket but I’m unsure if it’s a bios issue or motherboard issue if either one of these potential issues.
 

Bob.B

Commendable
Feb 8, 2021
1,610
197
1,490
31
Hello,

I recently was able to get an upgradable origin EON17-X which has an I7-7700k + GTX 1080. I decided to try to upgrade the cpu, I installed an I9 9900k I recently purchased. When I attempted to boot up the labtop, it wouldn’t even start. The power light would turn on for a split second then just shut off. I reinstalled the I7 cpu and it works fine. I’m confused why it wasn’t working because I know the labtop can have up to a 9900k because it’s an LGA 1151 socket but I’m unsure if it’s a bios issue or motherboard issue if either one of these potential issues.
Just a guess you have the 10 series.
You might need to contact origin to see what the upgrade path is.
 

ASK THE COMMUNITY

TRENDING THREADS