Question Out of boz Z390 Aorus Master & 9900KF wont post - Board LEDs flash white once then stay off

aj84763

Honorable
Jan 31, 2014
31
0
10,530
0
Hi All,

Just wanted to see if I'm missing something. I bought a new Z390 Aorus Master and a 9900KF on Monday to do a new build, being stuck at home for 4 weeks has suddenly given me the itch to go back into water cooling.
I'll get the basics out of the way first, yes all the cables are plugged in correctly, no nothing seems damaged and all the CPU pins seem fine.There's nothing physically visible which should stop this from working.

Experience has taught me to ALWAYS test the board and cpu on the box, don't build then have to rip everything out and start again. So I did this and I'm glad I did, upon powering the board for the first time I see the LEDs behind the Aorus logo on the chipset heatsink, and also on the ESS Saber logo covering the audio section, flash white for a split second then stay off. There's the first issue, aren't the lights suppose to stay on? Originally I thought nothing of it, tried to turn the board on with the power switch at the back and bubkus, nothing happened.No debug LEDs, no RGB rainbow puke, no Q LED post codes, no beeps, nothing.

I reduced down components, clearing the CMOS and removing the battery for 10 minutes after removing each component but unfortunately that changed nothing. I got down to only the CPU, both EPS cables, and the 24 pin, nothing else connected (no storage, no RAM, no GPU, nothing bar board and CPU). I tried removing the CPU and then got the red LED on the board above CPU, but re connecting brought me back to square one.

Since my power supply was a little old, a RM1000i, I decided I should try get a new PSU. Today I picked up a new AX850 (unfortunately everyone locally is sold out of the 1000 and I'm stuck to either the AX or HX as my custom cable mod cables only support those otherwise I would of moved to Seasonic). Hooked it up and this time I at least got the rainbow puke on my RAM but that sadly was the only thing to change. Just to make sure there's nothing wrong with the PSU I tried to boot my old i3 2100 system with both the old and new PSU and both worked fine.

I checked the masters CPU page and noticed that you need F7 or F8 for the 9900KF anyone know which one is required? The table has two lines with the exact same entries but different stepping and different bios minimums, but I'm not sure which stepping I would have. A few questions/clarifications I was looking for:

1: My board has the serial number starting sn2001500. My interpretation of SNs is the first lot should be the DOM which should work out to is it was made in the 1st week of 2020. Is that correct? If it is then I should already be on the latest BIOS so that should not be the issue.

2: The master does not support Q-Flash Plus does it? Obviously since the board wont boot the only way to update the bios would be with that, but AFAIK, and since the manual makes no mention of it, this board does not support it.

3: Is there anything else I can try to diagnose where the issue lies? I have already submitted a online ticket with support and am waiting their response, but was hoping here would be able to provide a speedier resolution. I've exhausted all me usual steps, normally removing a component or clearing CMOS resolves the issue but it seems like I've just gotten a dead out of the box board. Which unfortunately would be the third time this has happened
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts