Question overall problems

Aug 21, 2019
2
0
10
0
I'm having continual problems with fps and I don't know if it's my specs or a piece of hardware that's broken or what because there are some other annoying problems. I doubt its the specs because as far as I know, they are pretty good. But I'm by no means an expert.
I have:

CPU: AMD Ryzen 7 1700X Eight-Core 3.40 GHz
Motherboard: ASUS ROG Strix X370-F
Ram: GSkill Trident Z RGB DDR4-3200 2 8gb
SSD: Hitachi HP SSD S700 Pro 512GB
HDD: Seagate Desktop HDD 4tb
GPU: EVGA RTX 2070
PSU: Corsair CXM 650 W 80+ ATX PSU
Chassis: Fractal Design Define r6
OS: Windows 10

so like I said I'm not sure why I'm not getting great framerate I have a feeling it might be my GPU is faulty but I'm not sure because it might be my monitor. for example of what I mean by bad fps, it's not horrible just a lot worse than I feel it should be.

for instance: Assassins Creed Odyssey's recommended specs are 8 Gb of ram a GTX 970 and a Ryzen 5. and yet I can only get around 40 fps on average on ultra.

Finally, for some reason, my screen will just go blank and it won't come back on unless I unplug my DP cord and plug it back in. But sometimes it will flicker on by just jiggling the cord so it makes me think that it could be a problem with the port on the graphics card.

sorry if this is the wrong place to put this but I'm not sure where else I should.

Thanks!
 
Last edited:

Lutfij

Titan
Moderator
Might want to list your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

Then mention the make and model of your PSU as well as it's age. State the version of the OS you're on if Windows 10. You might also want to include the version of drivers for the GPU you're on. Latest BIOS update for your motherboard(sans the Ryzen 3000 AGESA code)?
 
Aug 21, 2019
2
0
10
0
Sorry for the late response. Here are the revised specs.

Not sure which you needed for the os version so
the OS build is 17763.557 and the version is 1809

CPU: AMD Ryzen 7 1700X Eight-Core 3.40 GHz
Motherboard: ASUS ROG Strix X370-F
Ram: GSkill Trident Z RGB DDR4-3200 2 8gb
SSD: Hitachi HP SSD S700 Pro 512GB
HDD: Seagate Desktop HDD 4tb
GPU: EVGA RTX 2070
PSU: Corsair CXM 650 W 80+ ATX PSU
Chassis: Fractal Design Define r6
OS: Windows 10

I Am using the latest drivers for my GPU and have updated in the past and can confirm that it does help but there are still issues

I'm not sure what an AGESA code is.

I am not on the latest bios but will update when I have the chance.
 

ASK THE COMMUNITY

TRENDING THREADS