P55A-UD4P Not Loading OS on Start-up


Sep 16, 2011
Hello all,

This is not a question, rather just populating the internet with a problem I had that is now fixed, even though I'm not sure what I did.

I have a P55A-UD4P mobo, two solid state HD's (OCZ agility 2 (60), and OCZ agility 3 (120)). My OS is installed on the agility 3.

I recently moved my computer to another room, and upon turning it back on for the first time, I would see the GIGABYTE image, then a typical quick start-up message (too fast to read), then when I was supposed to see "Loading Operating System..." I just saw "..." It would hang there forever, or sometimes even just shut down.

I tried the following to fix the problem.

Unplug everything unnecessary (turned off speakers, printers, modems, unplugged USB's, etc.)
Take out, swap, re-seat my RAM (I have 16GB total over 4 DIMMs of Kingston Memory)
Unplug two other HD/SSD's that the OS was not installed on.
Took my computer into the garage to dust it all off nicely.
I sat and thought about it for a while (that didn't do anything!)

Here's what worked...
In BIOS i changed a setting to not stop the start-up if keyboard errors were observed, but I don't think this helped my problem (i'll probably change it back)
I have a Razer Lycosa USB keyboard, and I think when I moved my computer I ended up plugging them into different USB slots. So, I changed them back.

Computer works fine.

I guess I'm just hoping that nobody else wastes 4 hours trying to figure out a 4 second problem.


Occasionally for no apparent reason the bios will switch from the OS hdd to another drive as the first boot option and maybe while you were in the bios it changed back to the OS drive as the first boot option. If your Pc fails to boot in the future tha's one f the things you could check.
It wouild also be a good idea to have the "no" option on stop with errors for the keyboard and mouse if there is one for that.