Question PC automatically shuts down after 10 secs.

Jun 26, 2019
4
0
10
0
Hello there,
i have a very old computer of compaq with intel pentium 4. (somewhat like compaq sr2170nx). The problem is that the CPU PC automatically powers off after about 10-15 secs.
I switch it on, i can hear the POST beep, and the american megatrends bios screen, the a: drive error and NVRAM loading (NVRAM loads windows 7).
It used to work fine even with the a: drive error, but today the problem started to show up. Also i thought if it was a problem of the NVRAM but around 15 tries i got the windows 7 loading screen for 1 second. Also the twist- i used to get the compaq bootloader (or whatever i am a noob) but today i got the HP invent bootloader! this never happened.
Also thats not a cooling fan failure because sometimes the fan buzzed at the max speed.
The computer is around 14 years old and also it had a VERY wierd error previous year which got fixed automagically.
Thanks,
 
Last edited by a moderator:

InvalidError

Titan
Moderator
The fan going crazy does not automatically mean that everything is fine temperature-wise, there could be poor contact between the CPU and heatsink causing poor or no heat transfer letting the CPU overheat.

At 14 years old, the computer may also be in need of a new PSU. I had to repair my P4's PSU about two years ago, mainly use it to drive my flatbed scanner which has no drivers beyond XP and gets 10-20h of use a year.
 
Reactions: pika777
Jun 26, 2019
4
0
10
0
Thanks for your reply! my computer never had hardware issues, but now i need to see a technician.
Btw today i did another try, it worked for around 25 secs today, and i found out that the fan only makes a buzz after the 'checking nvram, update ok' line, also today it gave me = 'failed to load windows error'
i tried to look into bios settings, and opening the cd-rom but couldn't.
Also fixed a voltage stablizer and UPS but still the same.
I noticed that the duration decreases after everytime i power on the cpu (without switching off the main supply).
Btw thanks,
+ okay somehow i read the bios screen whole, the thing which draws my attention-
'00 usb mass storage devices found and configured'
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS