Question PC booting, Display and USB dont work

Feb 1, 2022
2
0
10
Hello

I Built myself a pc 6 months ago, no problems until now.
I recently moved my computer and unplugged everything, now that I try to turn it on the power goes on fine, but USB devices wont work and display wont show anything either.
I looked up a few threads and I tried cleaning my computer and ram slots, but no change. Some threads say its a RAM problem, some say its PSU and some say MOBO.

I need help figuring out which component is actually the problem.


All parts expect are 6 months old, expect the gpu wich is 2 years old.
Taking display from MOBO instead of GPU has no effect.

Asus PRIME B450-Plus
Ryzen 5 3600
Kolink Enclave 600W
HyperX Fury 2x8 DDR4 2600mhz
Gigabyte GTX 1070
 
Last edited:

taylorwallace9

Distinguished
Apr 19, 2011
72
0
18,630
Having the exact same issue, PC boots but no display. My Razer mouse lights up but HyperX keyboard does not. I've tried another 6+2 PSU cord to the GPU (GTX 1070 as well) and still nothing. Im unsure if its a bad GPU or PSU.
 

taylorwallace9

Distinguished
Apr 19, 2011
72
0
18,630
Okay so I have dual channel ram, 32gb. I just removed one stick and now its working as normal. But at the same time, I kept the display cable (display port) unplugged. I plugged it in AFTER booting the PC. Im going to keep playing around and try to determine if its bad RAM now.

Edit: I turned the PC off, and again no display so I don't believe its a RAM issue. It seems to give me display once the PC is running, and then inserting a display cable.
 
Last edited: