Question PC Build Issue -- No Display?

Oct 31, 2020
27
0
30
0
Hello Everyone! I'm trying to build my own PC and I have listed the parts I used below. After assembling it and connecting it to power, the fans and cooler start moving, the Motherboard's lights turn on so it seems like everything is working but when I connected it to a monitor using HDMI to the Motherboard, nothing appeared on the display. Could someone please help me and tell me what the possible issue could be?

Here are the parts:
Parts:
CPU: Intel Core i5-10400
RAM: ADATA Premier, DDR4, 8 GB, 2666MHz, CL19 (AD4U266638G19-S)
Power Supply Unit: SilentiumPC Elementum E2 550W (SPC252)
SSD: Dysk SSD Samsung 970 Evo 500 GB M.2 2280 PCI-E x4 Gen3 NVMe (MZ-V7E500BW)
Network Card: Card WiFi Bluetooth 5 Gigabyte GC-WB1733D-I PCI-E
PC Case: Case Genesis Irid 503
Motherboard: Płyta główna MSI B460M-A PRO

Would really appreciate your feedback. Thank you!

Edit: I attached the Beep Test Speaker and no beeps are heard when I turn it on. When I disconnect ram 3 beeps are heard but otherwise no beeps.
 
Last edited:
Oct 31, 2020
27
0
30
0
Have you double-checked the RAM is pushed all the way down in it's slot, at both ends?
Have you tried using both RAM slots?
Have you tried booting with no drives connected to see if you can get into the BIOS?
I checked if the RAM is connected or not. If it wasn't surely there would be a beep like there was when I took it out on purpose. I'm not using both slots since I only have 1 8gb module. I have not tried booting without any drives yet. I am using an NVME drive.
 
Nov 21, 2020
14
2
25
1
You could also try to connect a screen using the DVI port if you have some type of monitor that supports it and see if that works
 
Oct 31, 2020
27
0
30
0
You could also try to connect a screen using the DVI port if you have some type of monitor that supports it and see if that works
Alright, thank you for the advice. My question, however, is that shouldn't there be one beep if POST is successful? I don't hear any beeps when all components are in and when they are not, for example when I removed the RAM, then I heard 3 beeps.
 
Oct 31, 2020
27
0
30
0
Are there any other possible solutions to the problem. I tried most of the ones listed above but none of them seem to work.
 

ASK THE COMMUNITY