[SOLVED] PC can't boot up, it is on but no signal on the monitor

blackarrow

Reputable
Apr 25, 2016
25
0
4,530
0
Hello

In last two months I got BSOD few times, especially when computer wakes up. Few days ago my PC would not boot up.

I tried to connect monitor directly to the motherboard (on-board VGA). I left only one memory card in the slot and tried three different memory cards. It was always the same, the PC is on, but I am not getting any signal to the monitor. Sometimes it restarts automatically but it is the same story again, it never boots up.

After few changes of slots for memory, PC finally booted up but not next time when I turned off PC and turned it on again. So, I am not sure what is the problem and how to solve it. I can't enter BIOS either.

i5-4670k
Gigabyte Z87-HD3
2 x 4GB Samsung DDR3
BeQuiet 500W
Samsung 256GB SSD
MSI GTX 1050Ti 4GB

Any help?

Thanks.
 
Nov 8, 2020
12
0
10
1
do you live in a place with where there's not that good of an eletricity ? i'm no expert nut i had been through something like that, sometimes it wont give signal until a day later. what i tried is switching rams as you mentioned and taking out the little battery on the motherboard then putting back in
 
Nov 8, 2020
12
0
10
1
do you live in a place with where there's not that good of an eletricity ? i'm no expert nut i had been through something like that, sometimes it wont give signal until a day later. what i tried is switching rams as you mentioned and taking out the little battery on the motherboard then putting back in
 

ASK THE COMMUNITY