Question PC clicking sound and lights flashing on start up

computerwonder

Distinguished
Jul 8, 2012
133
0
18,680
0
Hi all,

Just reinstalled my CPU cooler as wasnt happy with the temps. Upon plugging the PC back in, pressed the power on and i was greeted with clicking noise and my pc led fans flashing. Never had any issues with the pc before hand and is currently working flawlessly now.

Turned the pc off and pulled all the plugs out of the back and checked the connections on the pc to check i hadnt knocked anything all looked fine so hooked it all back up. All worked fine after this im thinking i didnt seat the power cable into the back of the pc correctly could this cause this as its the only thing I can think off?

Popped into bios to double check everything and my bios has been reset "clear cmos information BIOS has been reset please re config your bios". unsure if this is related or not. All the PC parts are 4 months old and havent had an issue to date, and the pc has been turning on and off fine all day.

PC Speccs

Ryzen 5 3600
AMD 5700xt
Gigabyte b550i
Corsair SF750 Platinum PSU
16gb Corsair ddr4 ram
 

Lutfij

Titan
Moderator
Yeah, you must've removed the CMOS battery or the jumper's placement. In either case, you should set some options in BIOS, like the storage controller to AHCI, enable Fast Boot(if you have an SSD) and that your ram is also set to it's advertised settings.

Might want to also check and see if the cooler's backplate is loose and making contact with the back of your chassis. Speaking of which, what is the make and model of your case?
 

ASK THE COMMUNITY