Question PC crashed and now stuck on splash screen whilst graphics card is plugged in

Jun 25, 2019
1
0
10
0
Hi,

Today I was gaming and the whole system froze (screen went glitchy and inverted colours, so I assume it was some kinda GPU crash?). After rebooting, windows now won't load past the intial windows splash screen, it just freezes and won't continue. I checked all the connections etc and cleaned out some dust, run memtest, chkdsk etc. But it still won't get past the splash screen (safe mode is fine, accessing BIOS is fine). However it DOES fully boot when I remove the graphics card and use integrated motherboard graphics!

Since the PC has been running fine for years, I suspect a hardware problem, presumably graphics card? Though is it possible something is slightly wrong with the PSU and it just can't handle the load with the graphics card plugged in anymore? Is there any way to diagnose / potentially fix the problem, before pulling the trigger on replacing a component (as I'm not certain which one is the problem)

Full specs:

CPU: Intel I7 4790 Quad Core
Motherboard: Gigabyte 1150 H81M
Ram: Corsair 8gb x2 (16gb) Vengeance 1600mhz
SSD/HDD: 1tb Sata Hard Drive
GPU: Nvidia GTX 760 2GB
PSU: 850w Aerocool VP Pro Power Supply
Chassis: ????
OS: windows 7

The system is about 4 years old so it would be a bit surprising if a component has completely died already I guess?

Thanks all!

edit: formatted specs
 
Last edited:

Lutfij

Titan
Moderator
When posting your system's specs, always list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

If the system abruptly rebooted/froze when taxed then the issue could be your OS, the PSU or the ram.
 

ASK THE COMMUNITY

TRENDING THREADS