Question PC crashed, now doesn't post and gets stuck in a boot loop (RMA'd the motherboard and still getting the same problem)

May 11, 2021
3
0
10
0
Specs:
Asrock b450m pro4
Amd ryzen 5 3600
16gb corsair vengeance lpx ram 3600mhz
FE 3060ti
EVGA 750 GQ

Two weeks ago my PC crashed (black screen) while browsing the web. After this, it entered a boot loop where it failed to post. The CPU and case fans weren't spinning, but the GPU and HDD were. I replaced all motherboard connectors, reseated motherboard in the case, tested each RAM stick individually in each slot, reseated CPU and fan, and reset CMOS. Resetting CMOS made the fans all spin up, but the PC still wouldn't boot. I have now RMA'd the motherboard, and was sent a new one (presumably because they tested and concluded my motherboard was faulty). After installing everything, the CPU fan and case fans still aren't spinning up, and the PC boot loops without posting. What could the issue be/next steps be for trouble shooting?
 

Ralston18

Titan
Moderator
PSU = EVGA 750 GQ. Correct?

How old? Heavy use for gaming, video editing, or even mining?

Do you have a multi-meter and know how to use it? Or know someone who does?

https://www.lifewire.com/how-to-manually-test-a-power-supply-with-a-multimeter-2626158

Not a full test as the PSU is not under load. However any voltages out of tolerance would make the PSU suspect.

If available try swapping in another known working PSU. Do not mix and match cables between existing PSU and the swapped in/test PSU.
 
Reactions: helper800
May 11, 2021
3
0
10
0
PSU = EVGA 750 GQ. Correct?

How old? Heavy use for gaming, video editing, or even mining?

Do you have a multi-meter and know how to use it? Or know someone who does?

https://www.lifewire.com/how-to-manually-test-a-power-supply-with-a-multimeter-2626158

Not a full test as the PSU is not under load. However any voltages out of tolerance would make the PSU suspect.

If available try swapping in another known working PSU. Do not mix and match cables between existing PSU and the swapped in/test PSU.
Thanks for the reply.

Yeah that's my PSU, EVGA 750 GQ. My PC is just under a year old, used it for gaming maybe 4-8 hrs week, and some light music production.

I don't have a multimeter but I know how to use one. I'll try getting one and testing the voltages. Unfortunately I don't have another PSU to test with. Also I reset CMOS and now the case and CPU fans are all spinning, and the GPU and HDD power up but still no POST. Starting to suspect my CPU
 
May 11, 2021
3
0
10
0
I tried a new CMOS and it didn't work. Gave it to a PC shop and they said the CPU was dead - I think the motherboard died and took the CPU with it.
 

ASK THE COMMUNITY

TRENDING THREADS