Question Pc crashed windows stopped worjing and usb ports started smelling bad

Sep 23, 2019
3
0
10
0
So a little while back like 1 week i made my build i left it to do at the pc shop they made the wiring etc only thing i did today i buyed a SAPPHIRE RX 5700 XT GPU from radeon and switched it for the gigabyte 1050 Ti OC and everything was cool i ran two benchmarks on far cry 5 and battlefield 1 smooth as hell and everything good after that i went to learn for a math exam on a website suddenly the PC shut down restarted and went to windows the icons were good and all but background was black next thing the pc ran into a problem and restarted it said "your PC ran into a problem well fix it just collecting data for crash report" then it said that i need to choose an option safe mode continue to windows fix problem etc i chose start in safe mode and fix problem but after that the pc shut down and on again screen was black and i smelt some kind of like plastic burning not much just a little i shut down the pc immediately and unplugged it from everything i smelt on the PC and the smell came from the USB ports regular ones that are black in color the smell came from there so i dont know anymore i will bring the PC to the shop tomorrow and tell the what happened but do you have any ideas what it could be?

SPECS:
Cpu: ryzen 7 3700X
GPU: SAPPHIRE RADEON RX 5700 XT
Ram: 2x8 GB crucial ballistix 3000MHz tracer RGB
Motherboard: X570 aorus elite
Psu: thermaltake toughpower grand 650W RGB
Case: thermaltake level 20 MT argb
 

Lutfij

Titan
Moderator
By USB ports, you're looking at the one's at the back I/O right? If they're at the front, then you should be pinning the issue to the front panel of the case. In fact, I'd ask you to look through the wires in the case. Were the USB ports occupied by any peripherals or open to air?
 
Reactions: Matic krajnc
Sep 23, 2019
3
0
10
0
By USB ports, you're looking at the one's at the back I/O right? If they're at the front, then you should be pinning the issue to the front panel of the case. In fact, I'd ask you to look through the wires in the case. Were the USB ports occupied by any peripherals or open to air?
Yes i mean the back ones by the I/O shield they smell lightly burnt nothing else just the usb ports and another thing i noticed when i shut it down before that the front three 120mm fans were blinking a bit like theyre losing power or something but the lightning mode was set to static red
 
Sep 23, 2019
3
0
10
0
Another thing i noticed is when i tried rebooting it it black screened and the keyboard abd mouse didnt have the lights turned on so i suppose the usb ports are dead. Or something i do not see another solution because everything worked fine the other thing is i just updated the drivers on the gpu that is all nothing else so if you have any other solution please help because i am really worried i worked through all my summer vacation to get the money for this pc
 

HoT_TaCTiiCtZ

Reputable
Mar 7, 2015
10
0
4,510
0
Whoa, I am SO SORRY to hear about this! Did you ever RMA the board or somethin'? I can't believe that MB did that so soon! I read it's release date said it came out THIS YEAR! (unless the wrong MB popped up on Google lol) I've seriously had a PC Build from 2013-ish which is the GIGABYTE Z87x UD5H MB, surprisingly it's still up and running with no problems. I even recently got Thermal paste from the CPU inside the Socket and kind of uh... Kind of took the CPU out, sprayed into the socket with 90% Rubbing alcohol using one of those water spray bottles you use to spray the cats with when they're hiding under the dining table (lol)

TO MY SURPRISE it still powered on and hasn't given any issues!!! (Been about 3 weeks since that happened) I didn't even clean all the paste out of the socket completely! LOL. Yeah, sorry I got off-topic, let us know what happened though! I'm eager to know because I'm getting a new MB soon later this year or at the beginning of 2020 so I want to know how hard it is to RMA a part if anything goes sideways...
 

ASK THE COMMUNITY