Question PC crashes randomly

Dec 5, 2019
5
0
10
0
Hello,

Since a few weeks I am experiencing some random crashes/freezes/reboots on my desktop. Since a few days these crashes are getting more frequent. From where it would happen once a couple days, it now happens every few hours.

I started experiecing the problem while gaming on windows 7, with my old hdd and 8 gb of ram. That’s when I started to look up on the internet and see if I could find a solution. In the beginning it started with a single freeze while I was gaming, the pc rebooted, after rebooting I noticed that I couldnt open any file or program on my hdd - it wasnt spinning (I have OS on my ssd). I restarted my PC and it was fixed. But this problem went on a couple more times. So I Checked my drives with hard disk sentinel; it said that there were many problems with my hdd, also 9 years old, so i bought a new one (+ 16gb ram because wanted that too). Backed-up all my files, clean installed windows 10 on my ssd and put my backed up files back on my new hdd. I formatted my old hdd afterwards, its still connected but not using it at the moment.

fast forward - after w10 install I didnt have any problems for 2 weeks. Then I got a crash, following days more crashes started to happen, also more often. While gaming, while doing nothing, at boot, after couple hours, just random!

Couple things I did to try fixing this;
Event viewer says: kernel power error 41 - changed some power settings, turned off auto driver download, disabled duplicate audio

checked all temperatures with open hardware monitor; everything shows fine

cleaned files and junk with ccleaner

Updated gpu drivers

did system restore and uninstalled latest updates, also did a system rewind to restore system back to when it was working without problems

Also yesterday, this happened only once so far, my keyboard wasnt starting when pc

My PC specs are:
Windows 10 home 64 bit
Motherboard MSI Z97 gaming 5
Bios date: 6/27/14
Processor: i7-4790K CPU 4.00GHz
GPU: Nvidia GTX 1070
RAM: 2x8gb
PSU: Antec EA-750 750w, about 8 years old
DirectX12

Hope someone here can help me, would be grateful!
 
Last edited:
Dec 5, 2019
5
0
10
0
Thank you for your quick reply.

I am also on 1909 windows 10.

I checked the version of my BIOS - it is indeed V1.4B0.

I will check the site and update the BIOS!

You think that might solve the issue? Will post once I updated and experienced any problems.
 
Dec 5, 2019
5
0
10
0
So I tried to update my BIOS to the latest version. Downloaded the file for my motherboard typ from the msi site to usb flash, rebooted, ran m flash, selected the downloaded file, system went to update bios, update got stuck at “updating bios me ... 100%” after 10 minutes I rebooted. The version remains the same.
 
Dec 5, 2019
5
0
10
0
I'm assuming by that date for your BIOS, you're on version 1.4, currently for your BIOS on that board? If so, please update the BIOS manually working your way up to the latest found on their support site. Which version of Windows 10 are you on? We're currently on 1909.

You also forgot to mention the make and model of your PSU and it's age.
tried to update bios but didnt work, read above. Should I try again?
 
Dec 5, 2019
5
0
10
0
@
You also forgot to mention the make and model of your PSU and it's age.
fixed. Any idea?

9th dec update: I managed to flash my bios to the newest version. Will be testing the next days if I experience any problems. Will post back soon.
 
Last edited:

ASK THE COMMUNITY