Jan 19, 2021
2
2
15
0
Hello,
Since a few days my PC keeps crashing many times a day (sometimes bluescreen/sometimes blackscreen, where I have to turn the pc off manually).
But it seems pretty random, when it crashes and I cant really replicate it. Sometimes its under load in games, but then I can play games 2 days straight without any problem and then it crashes while surfing.
Hardware:
Mainboard: B350M PRO-VDH
CPU: AMD Ryzen 5 1600
Cooler: Ben Nevis Advanced
RAM (old): 8GB 2x4GB Crucial Ballistix DDR4 - 2400
RAM (new): 16GB 2x8GB Corsair Vengeance LPX DDR4 - 3200
GPU: GTX 1060
PSU: Corsair CX450
Drives:
  • Samsung 970 Evo Plus M.2 250GB
  • Samsung 860 Evo 250GB
  • Crucial 240GB SSD
  • 1TB HDD
  • No OC at all
PC was built like 3 years ago. The 2 Samsung SSDs were added about 1,5 years ago.
A few weeks ago I wanted to upgrade my ram and replaced my 2x4 GB kit with a 2x8GB kit. And while I was on this I reseted my pc.
This all worked for like 2 weeks and then crashes started happening, like I already described but these were mostly bluescreens.
Of course the main sus was the ram, so I tried using my pc with the single sticks of the kit and tried differned slots, still didnt work. I used the xmp profile and adjusted the timings the way they were written on the ram stick itself. Both didnt work. I ran 1 pass of memtest 86 without an error. Then I used my old ram kit but it also didnt work and my pc kept crashing.

So I tried to search for the part that was causing the problem, I run many types of benchmarks but I came to no conclusion.

Some other things I noticed / I tried / I want to try
In the last couple of days it were mostly blackscreens
The PC freezes but I can still move my mouse for a few seks until the screen turns black.
While the blackscreens happens the debug led of the cpu on my mainboard lights up
After one crash my pc boots really slow and keeps crashing a few times after some seconds in windows. After some crashes it starts working again.
All the temps are fine

Bios on updated
I tested all the drives with CrystalDiskIndo/Mark

Things I can still do are cleaning my whole PC
reset my pc again
do all the drivers again
And today I got a new psu, because thats my main suspect now after reading some more about these kinds of problems.

Thas all the information I have, just ask if u wanne know something.

Thanks in advance!
 
Hello,
Since a few days my PC keeps crashing many times a day (sometimes bluescreen/sometimes blackscreen, where I have to turn the pc off manually).
But it seems pretty random, when it crashes and I cant really replicate it. Sometimes its under load in games, but then I can play games 2 days straight without any problem and then it crashes while surfing.
Hardware:
Mainboard: B350M PRO-VDH
CPU: AMD Ryzen 5 1600
Cooler: Ben Nevis Advanced
RAM (old): 8GB 2x4GB Crucial Ballistix DDR4 - 2400
RAM (new): 16GB 2x8GB Corsair Vengeance LPX DDR4 - 3200
GPU: GTX 1060
PSU: Corsair CX450
Drives:
  • Samsung 970 Evo Plus M.2 250GB
  • Samsung 860 Evo 250GB
  • Crucial 240GB SSD
  • 1TB HDD
  • No OC at all
PC was built like 3 years ago. The 2 Samsung SSDs were added about 1,5 years ago.
A few weeks ago I wanted to upgrade my ram and replaced my 2x4 GB kit with a 2x8GB kit. And while I was on this I reseted my pc.
This all worked for like 2 weeks and then crashes started happening, like I already described but these were mostly bluescreens.
Of course the main sus was the ram, so I tried using my pc with the single sticks of the kit and tried differned slots, still didnt work. I used the xmp profile and adjusted the timings the way they were written on the ram stick itself. Both didnt work. I ran 1 pass of memtest 86 without an error. Then I used my old ram kit but it also didnt work and my pc kept crashing.

So I tried to search for the part that was causing the problem, I run many types of benchmarks but I came to no conclusion.

Some other things I noticed / I tried / I want to try
In the last couple of days it were mostly blackscreens
The PC freezes but I can still move my mouse for a few seks until the screen turns black.
While the blackscreens happens the debug led of the cpu on my mainboard lights up
After one crash my pc boots really slow and keeps crashing a few times after some seconds in windows. After some crashes it starts working again.
All the temps are fine

Bios on updated
I tested all the drives with CrystalDiskIndo/Mark

Things I can still do are cleaning my whole PC
reset my pc again
do all the drivers again
And today I got a new psu, because thats my main suspect now after reading some more about these kinds of problems.

Thas all the information I have, just ask if u wanne know something.

Thanks in advance!
First thought, has it crashed again since changing the PSU?

Next thought- you mention bluescreens, can you take a photo of a bluescreen and post it? What specific bluescreen message is it as that typically gives info on what the error is related to (for example a graphics crash will usually point at a gpu driver). If it's graphics card related you can potentially improve things by doing a full clean gpu driver install by running the DDU uninstaller first then installing latest fresh drivers direct from nVidia. You might also want to check the condition of the gpu - you mention temps are ok however have you checked both the gpu and cpu? The 970 is fairly old now so might need fresh thermal paste and a clean. It's also possible the card is wearing out. If that looks like it might be the issue it could be worth testing it in another machine to be sure.

The other likely culprit is the motherboard - mainboards do fail sometimes and when they start to go wrong they can cause a multitude of weird errors. It's interesting that after the crash the cpu light comes on - it could even by an issue with the cpu, although cpu's are usually pretty stable if not overclocked and kept cool so I would say the motherboard is more likely the problem than the cpu itself.
 
Jan 19, 2021
2
2
15
0
First thought, has it crashed again since changing the PSU?

Next thought- you mention bluescreens, can you take a photo of a bluescreen and post it? What specific bluescreen message is it as that typically gives info on what the error is related to (for example a graphics crash will usually point at a gpu driver). If it's graphics card related you can potentially improve things by doing a full clean gpu driver install by running the DDU uninstaller first then installing latest fresh drivers direct from nVidia. You might also want to check the condition of the gpu - you mention temps are ok however have you checked both the gpu and cpu? The 970 is fairly old now so might need fresh thermal paste and a clean. It's also possible the card is wearing out. If that looks like it might be the issue it could be worth testing it in another machine to be sure.

The other likely culprit is the motherboard - mainboards do fail sometimes and when they start to go wrong they can cause a multitude of weird errors. It's interesting that after the crash the cpu light comes on - it could even by an issue with the cpu, although cpu's are usually pretty stable if not overclocked and kept cool so I would say the motherboard is more likely the problem than the cpu itself.
I think I fixed the Bluescreens, they were caused by missing/broken Wifi drivers. But I cant be really sure yet, just intsalled them now. I also let ddu run and reinstalled the gpu drivers. But the question is if that will fix the blackscreens too, that are the way bigger problem. If not my new psu should arrive the next days and then Im gonna clean the whole pc and check every connection etc. And maybe that will fix my problems.
 

ASK THE COMMUNITY