PC crashes under load, but is still slightly responsive

Chucky3375

Commendable
Jul 7, 2016
7
0
1,510
0
Hi, recently I bought some RGB fans and since rigging them up after 5 minutes, sometimes up to an hour of gaming my PC just stops, freezes and I need to force power down to get it working again after turning it back on. Strange that sometimes during the crash my mouse is working, I'm able to click things such as icons, start menu etc however upon clicking anything, nothing is responsive. I thought my CPU being too hot was the problem, I replaced the thermal paste, same thing happened. I then thought it was my GPU, so I rolled back the latest Nvidia drivers and all was fine for about two days, however I bought a liquid cooler for my CPU and installed it Today. Idle temps are now 28-32c, (used to be 45+ and in game almost 70c but I imagine that now be less with the liquid cooler, I just can't really test it). 5 minutes in game and it crashed again. Can someone please give me some ideas? I'm not sure if you need my specs so I'll post just in case. The GPU is also around 70-80c while under load.

i7 4790K 4ghz (not overclocked)
16GB 3.2K Corsair RAM
Corsair VS650 PSU
GTX 1070
SSD/HDD
GA-Z97P-D3 Mobo

Not sure if I missed anything sorry if I have. Thanks in advance.
 

Chucky3375

Commendable
Jul 7, 2016
7
0
1,510
0
UPDATE:

I took my kids GTX 1050 Ti and put it in my PC to see if it's the graphic card and it now works perfectly, but that GPU doesn't require the 8 pin connector from the PSU. I really don't think it's the GPU I've never OC'd and it's only one and a half years old, the PSU is hitting 18 months old and I read my PSU is prone to failure. So I bought a PSU and will update again Tomorrow in case any one else has a similar problem in the future.
 

ASK THE COMMUNITY

TRENDING THREADS