PC crashing in different forms while gaming, almost brand new pc

ryonost

Reputable
Jun 10, 2015
7
0
4,510
0
To begin, the specs:

Gigabyte A320M -S2H 1.1(I got it updated the moment from I bought it from the store)
Ryzen 5 2400G
8(8x1) GB Corsair LPX 2400Mhz
Sapphire RX 570 Nitro+ 4GB
SanDisk 120 SSD + 1 TB WD 7200rpm HDD
High Elements 750W psu

I have first started to experience problems while playing Shadow of the Tomb Raider and Battlefield 5. The first problem I encountered was, the game would freeze and crash, the screen would go black and the monitor would lose signal. I'd restart and see a notification saying "Default Radeon WattMan settings have been restored due to unexpected system failure". I researched online and tried many things. Using DDU, uninstalled graphics drivers and reinstalled latest ones and ones branded WHQL. I uninstalled MSI afterburner and its components. It seemed Ok for a while but then games would still crash and the problem this time was "has been blocked from accessing graphics hardware". I researched online and did the following things: sfc /scannow and the DISM checks, added TdrDelay and modified it to 8(tried 10 as well) on regedit(tried both Q-word and Dword) and tried other GPU drives using Driver programs(driver booster, drivereasy). I tried not installing hdmi audio drivers and I tried not installing radeon settings. I tried putting the ram stick on different slots.

I am not sure as to which component is failing. I ran UserBenchmark and it was fine, I tried FurMark and Heaven benchmarks for GPU testing and they were all alright.

I have used the psu for some time with my previous build as well and encountered no problems whatsoever.

The ram, the gpu, the cpu and the motherboard are brand new.

Last night I ran Windows Memory Diagnostic Tool and it detected "hardware problems". I ran it twice on different ram slots using the same ram stick. 1 time it encountered no problems and on the rest it did.

Nothing is overheating, thermal pastes and the tempratures are perfectly fine(under load mobo 60c max,gpu 58-60c max and cpu 55c max).

I suspect there might be a problem regarding the bios, should update it again?
Could someone please lend me a hand?

I also suspect the gpu, when I get home I'll try removing the gpu and trying games with Integrated gpu and see if the problem still persists, either way can the problem be regarding the gpu?

Could someone please lend me a hand?

Edit: I have now realized through some photos I took the BIOS version installed is for Gigabyte A320M -S2H 1.X not for Gigabyte A320M -S2H 1.1. I reckon the guy at the store installed the update for the wrong rev. Could this be causing the problem?
 

ASK THE COMMUNITY

TRENDING THREADS