Question Pc decided to shut down mid bios update

May 22, 2020
2
0
10
0
Been troubleshooting some cpu problems and decided to try a bios update. Thought I could handle it but apparently not because it shut down on its own mid update. I've tried some different things but nothing has worked. I have my boot disk but I have no display. When the pc starts up I get all the lights and fans in the case but no display or perephials. Im assuming its done for but figured I'd ask and see if I'm lucky enough to get the display to work so I can load the disk
Specs:
Mobo-asus x470-f
Cpu- ryzen 7 2700x
Gpu -msi 1660ti
Ram - corsair vengeance 2x16 ddr4 3200
 

DMAN999

Reputable
Ambassador
Try Clearing CMOS using these steps:
Unplug the PC (PSU).
Then press the Power Button for at least 30 seconds.
Use a flat headed screwdriver to short the CLR CMOS (CLRTC) Jumper (Touch both jumper pins with the screwdriver) for at least 15 seconds.
Plug the PC back in.
Press the Power Button to turn the PC on.
Repeatedly tap the DEL key
A screen should come up telling you to press the F1 key, do that.
Set the Optimized Default settings and Press OK (this is on the EXIT tab)
Save and exit the BIOS.
Tap the DEL key again to enter the BIOS and change any settings you want changed then save and exit again.
 
May 22, 2020
2
0
10
0
Try Clearing CMOS using these steps:
Unplug the PC (PSU).
Then press the Power Button for at least 30 seconds.
Use a flat headed screwdriver to short the CLR CMOS (CLRTC) Jumper (Touch both jumper pins with the screwdriver) for at least 15 seconds.
Plug the PC back in.
Press the Power Button to turn the PC on.
Repeatedly tap the DEL key
A screen should come up telling you to press the F1 key, do that.
Set the Optimized Default settings and Press OK (this is on the EXIT tab)
Save and exit the BIOS.
Tap the DEL key again to enter the BIOS and change any settings you want changed then save and exit again.
I tried do that just now and to no avail. Still have no power to my perephials and no screen, I also tried it a second time but removed the battery as well. And for what its worth the red led for the cpu is on but I checked over the cpu for any physical damage and found none.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS