Question PC disconnecting all peripherals. Display ports/HDMI from video card included.

Aug 21, 2020
3
0
10
0
So this will be my second post here.

Within the last 4 - 5 months this scenario has happened twice and I'm not sure why.

Randomly without any rhyme or reason it seems my pc will randomly disconnect all my peripherals. Monitors, mouse, keyboard, microphone, everything. My pc being right next to me shows that it's still on and running but holding down the power button doesn't shut it down and I'm forced to flip the power supply on and off. It feels almost as if there was something like a small power outage but once again, only the peripherals are disconnected while the pc itself still seems to be on and no other electronics (as far as I can tell) have flickered due to an outage.

The first time this happened apparently we did have an outage as my dad said his pc shut down and rebooted but I have no way to tell if that happened as well this time. As it is the second time this happened I feel like posting about the issue for some input would be a good idea and thus I'm here.

To lay out some things:
-Nothing comes back on after the disconnect. Video is still gone, no response or lights from the keyboard or mouse either
-I'm still able to use my other devices connected to my monitors
-Windows does not check anything or repair drives on reboot, seemingly as if there were no issues previously.

If anybody has experienced the same or similar scenarios and is able to give any input, it's much appreciated. I'm hoping this may just be a system thing where it's just doing it protect itself but I'm not sure at this point.

Thanks in advance.

Forgot to include components (sorry and thanks for reminding me in the replies)

Asus ROG b450-f motherboard
Ryzen 7 2700
Corsair vengeance LPX @3000mhz
Gigabyte RTX 2070 gaming OC
Cougar GX-S 650W 80+ gold PSU
 
Last edited:

ASK THE COMMUNITY