Question PC Display/GPU Issues

May 8, 2019
3
0
10
0
I’ve had a custom built PC for the last three years now which has worked great for the first two years until I began experiencing significant issues over the past ten months or so. All of them seem to be connected in some way to my display, and I’m interested in purchasing a new GPU but want to see if anyone can confirm the source of my problems or suggest any solutions before I go replacing any parts.
First problem I’m having is probably the most significant in that occasionally without warning or without pattern between occurrences, my PC’s display will freeze completely. I can still hear the sound from whatever application I had open and can usually still interact with my PC (either by pressing buttons that give audio feedback or by changing the lighting setup on my keyboard) meaning that I don’t think it’s my entire PC crashing. Attempting to unplug and plug in my display port cable during this either results in the display just returning to the same image it was frozen on previously or my monitor failing to recognize any input from the source, with my only option to perform a hard shut down on my PC. This has happened on dozens of occasions when I’m in-game or running GPU intensive programs, but also is equally as common when I’m just browsing the internet, using apple music, or simply having my computer idle on the desktop. This problem usually occurs within the first several minutes from booting up my PC, and if my computer makes it past that period I have no issues afterwards until I restart my computer.
The second issue I’ve been experiencing is a huge lack in GPU performance consistency. Given that I don’t overclock any of my components, my GPU typically remains at its constant base speed of 1013 MHz. However, I will occasionally start up my PC and without warning my computer will struggle to even display programs like Microsoft word or google chrome without exceeding 60% GPU load, occasionally even staying at 90% for several seconds when the PC is just running idly, meaning that running any program even more GPU intensive during this period is practically unfeasible. During this time the only indicator I have from my component monitoring software is that the GPU clock speed ranges anywhere from 850-1260 MHz. I’ve found that to stop this I only have to restart my computer and it usually corrects itself, the only problem is that it occasionally takes several tries to restart my computer before my monitor actually recognizes there is a display input from the source.
For both issues which actually began occurring around the same time without warning I found that having changed out my display port cable reduced both problems’ frequency significantly however now even after changing my display input cable multiple times this no longer seems to affect how often the problems occur. I’ve observed with the exception of my GPU clock speed and load changing erratically as explained earlier I don’t have any anomalies I can observe; GPU and CPU temperatures remain around 40-65C and 20-30C respectively, CPU clock speed remains around 4021MHz, and RAM load remains around 30%. Does anyone have any advice or previous experience with any of these problems? I am willing to buy new components if necessary, and have left my spec list at the bottom. Thank you for any help or advice.

CPU: Intel Core i7-6700K TDP: 95W
Stock Frequency: 4000 MHz

GPU: NVIDIA MSI - GeForce GTX 980 Ti 6 GB Video Card TDP: 250W
Default Clock: 1013 MHz Turbo Clock: 1101.5 MHz

Motherboard: Z1701 PRO GAMING Chipset: Skylake
BIOS Version: 0806 BIOS Date: 02/15/2016

RAM: Kingston HyperX Fury Black 8GB DDR4-2133 Memory (x2)
Default Frequency: 2143 MHz

Storage: Samsung SSD 850 PRO 512GB (24 GB Free)
Western Digital - Caviar Blue 1 TB 3.5" 7200RPM HDD (111 GB Free)
 
May 8, 2019
3
0
10
0
As an update,
I've updated my BIOS, Utility, and Chipset drivers for my motherboard. For the first two days after having done so, everything worked great and I was able to use my computer without any errors. However now my PC has gotten even worse with the freezing to the point where I am never able to use my PC for more than three minutes before it freezes with no option other than to do a hard reset. I'm now convinced my GPU is failing and needs to be replaced.
 

ASK THE COMMUNITY

TRENDING THREADS