Question PC doesn't always detect shucked WD 8TB White drive after sleep or startup

Mar 29, 2019
5
0
10
0
Long story short. Seemingly at random my windows 10 PC decides to detect or not detect my WD 8TB shucked easystore white drive after either initial boot up or from sleep mode. Sometimes it does detect it, sometimes it does not. I'll restart the PC many times, sometimes it will take 5 or 10 times for my PC to finally detect the drive. Other times it will detect on the first try. If the PC doesn't shut off or doesn't go into sleep the drive is fine.

I've scoured the internet for answers and there doesn't seem to be a definitive answer. I've tried all the nonsense like going into power settings and preventing the hdd's from sleeping and all that stuff. Updated my bios. I've tried replacing the SATA cords, I've tried plugging it into a different sata slot on the motherboard. Nothing seems to have worked. After I replaced the SATA cable it did work for maybe a day (it worked through several cycles of wake and sleep) but then it eventually stopped working again. I don't know if it was a coincidence or not that I just replaced the SATA cable.

Some promising fixes that eventually stopped working is I put the 8tb drive higher on boot priority in the bios. It worked for maybe a day. Also I replaced the SATA cable and again it worked for maybe a day. I don't know if these were coincidences or what.

I've read somewhere that some suspect with the larger drive the longer boot up time prevents windows from recognizing it when starting up, which kind of makes the most sense to me. But I don't know how I could fix that. I've read to uninstall some magician program, or wd programs, but as far as I can tell none of these programs are installed on my pc.

I've installed 2 1TB WD Blue drives in the past with no problem. I was using an old 2TB WD external for a long time as well, also with no issues. One thing I will say is when I first installed the drive into my PC it already seemed to be formatted correctly so I did not have to format it or anything else, it seemed good to go and my PC recognized it right away and automatically gave it a letter and all that. I'm wondering if formatting it would help or not.

Please help, this issue is driving me crazy. Thanks.

Motherboard is asus Z170-AR
i7 6700k
EVGA 650W power supply
8x2 GSKill Ripjaws 5 memory
EVGA 1060 SC graphics card
 
Last edited:
Is that a retail WD drive version?
Where did you get it?
I have one and does not behave that way and it was not formatted
What's the type of format?
I suggest you format the drive in Windows using NTFS-GPT.
Just in case, check the drive warranty on WD website and check the drive with Crystaldiskinfo to see how long it has been in use.
 
Mar 29, 2019
5
0
10
0
Is that a retail WD drive version?
Where did you get it?
I have one and does not behave that way and it was not formatted
What's the type of format?
I suggest you format the drive in Windows using NTFS-GPT.
Just in case, check the drive warranty on WD website and check the drive with Crystaldiskinfo to see how long it has been in use.
Hi, thanks so much for replying. I bought the drive as an 8TB external WD easystore from I think bestbuy. I bought it because I knew it was shuckable, and so I did that and put it in my PC. It appeared new to me.

Here is a pic of what the drive looks like in the control panel. I didn't format it in any way it just showed up like that when I installed. Obviously I put some data on there though. I doubt how it's formatted would be the problem but figured I'd include that info just in case.



edit: I ran the crystaldiskinfo thing and it says power on time is about 5 days 8 hours which sounds about right. Also health of drive is "good".

I did notice that the drive in question has "APM" or "Advanced Power Management" while the other 2 1TB blue drives do not. I wonder if some sort of power management within the drive itself is the issue here?









 
Last edited:
So you purchased an external hard drive, you removed the enclosure and you are using it as an internal SATA HDD. That's the reason why it was formatted and you're encountering that issue.

The power management (APM) on the WD external drives firmware is more aggressive than internal drives.
It's set to only wake up the drive when an access command is issue and then place the drive in a sleep state and that could be why sometimes it does not appear.
Changing the Power Management on Windows won't work since it is written into the WD HDD firmware.
Changing the APM on the BIOS might work, but that will shorten the life of the WD HDD, since it was not designed to be running or spinning at that rate.
Some WD SATA drives come with a AMP jumper next to the SATA port, removing this jumper will disable the APM. Again that will shorten the life of the WD HDD, since it was not designed to be running or spinning at that rate.
 
Mar 29, 2019
5
0
10
0
So you purchased an external hard drive, you removed the enclosure and you are using it as an internal SATA HDD. That's the reason why it was formatted and you're encountering that issue.

The power management (APM) on the WD external drives firmware is more aggressive than internal drives.
It's set to only wake up the drive when an access command is issue and then place the drive in a sleep state and that could be why sometimes it does not appear.
Changing the Power Management on Windows won't work since it is written into the WD HDD firmware.
Changing the APM on the BIOS might work, but that will shorten the life of the WD HDD, since it was not designed to be running or spinning at that rate.
Some WD SATA drives come with a AMP jumper next to the SATA port, removing this jumper will disable the APM. Again that will shorten the life of the WD HDD, since it was not designed to be running or spinning at that rate.
Thanks, but you seem to be saying it's a problem inherent with using the drive internally. If that's the case, then why is it only a problem for me and not the other thousands of people doing the same thing?

In any event, how would I be able to change the power management in bios or this jumper thing? At this point I just want to get it working and i'm not terribly concerned about longevity.
 
Check your WD HDD and see if it has a jumper. Remove the jumper to disable APM.
If it doesn't have a jumper, then go to your BIOS. The AMP configuration is available under the Advance tab on Asus motherboards.

Those other users might have remove the jumper from the HDD, change BIOS settings on their motherboard or got a different HDD model that the one you have or the same model with different firmware. There are too many variables present to compare your setup to others.
I have several WD HDD with the same model but different firmware.
You cannot compare your setup to others, since you do not have the same hardware they might have.
 
Mar 29, 2019
5
0
10
0
Check your WD HDD and see if it has a jumper. Remove the jumper to disable APM.
If it doesn't have a jumper, then go to your BIOS. The AMP configuration is available under the Advance tab on Asus motherboards.

Those other users might have remove the jumper from the HDD, change BIOS settings on their motherboard or got a different HDD model that the one you have or the same model with different firmware. There are too many variables present to compare your setup to others.
I have several WD HDD with the same model but different firmware.
You cannot compare your setup to others, since you do not have the same hardware they might have.
Thanks. I will have to check for this jumper thing a little later. It seems like that is my last hope. I looked in my BIOS where you said and everything was already disabled under the APM section, so not sure if I'm supposed to change anything there or not.
 

popatim

Titan
Moderator
I have one of these as well and do not have this issue. The HTPC it is in sleeps several times a day and my wife would certainly let me know if anything was preventing her from watching her shows. LoL

I did not remove any jumper though I did reformat the drive. I messed up cloning the original 2tb ntfs to the 8tb and thinking I was all set. NTFS partitioned as MBR has a max partition size of 2tb you see... Repartitioning as GPT fixed that issue but I spent all night copying the data back in. LoL

You may have a boot delay setting in the bios to help give time for drive detection. I would enable it if you do.
 
Last edited:
Mar 29, 2019
5
0
10
0
I have one of these as well and do not have this issue. The HTPC it is in sleeps several times a day and my wife would certainly let me know if anything was preventing her from watching her shows. LoL

I did not remove any jumper though I did reformat the drive. I messed up cloning the original 2tb ntfs to the 8tb and thinking I was all set. NTFS partitioned as MBR has a max partition size of 2tb you see... Repartitioning as GPT fixed that issue but I spent all night copying the data back in. LoL

You may have a boot delay setting in the bios to help give time for drive detection. I would enable it if you do.
Ok, will look for that boot delay setting. Any idea what I should set it to if I find it? Do you know if that applies only at startup or from sleep mode as well?
 
ISTM that people are confusing APM with PUIS (power up in standby). The PM2 jumper on WD drives enables PUIS when installed, but only if the firmware is configured to look for it. PUIS can also be enabled/disabled via software (eg HDAT2).

BTW, I believe that the WD80EMAZ is a rebadged HGST helium model. Therefore I doubt that there will be a PM2 jumper.
 

ASK THE COMMUNITY

TRENDING THREADS