Question PC doesn't boot, GPU/CPU/PSU and exhaust fans are all spinning but no signal ?

Sep 16, 2021
3
0
10
0
So I just got a PC delivered after a few weeks of waiting (its an international shipment) and when I held the box, I heard some rattling.
When I look inside (without opening the case) I saw the ram sticks are both disconnected and just laying around.
I opened the case, plugged them in (its an ITX board with 2 slots, so there are no mistakes in plugging them in), I powered it and all the fans are spinning (gpu fan, cpu cooling fan, PSU fan, and another exhaust fan connected to the MOBO) but nothing happens.

My monitor is plugged into the GPU, I tried using 1 ram stick at a time at different slots, tried it with both of the sticks, I tried to replug all of the power cables going from the psu to different components I tried reseating the GPU
But no luck with all options.
What could it be? is there a chance the motherboard is dead, perhaps the sticks knocked off a capacitor or something from the motherboard?
I will try my friend's ram in a few days, and I will try my ram in his PC.
All repair stores are closed for some time so I can only troubleshoot by myself.
Can someone help me identify the problem?
Parts list -
GPU - Zotac 1660 Super
CPU - Ryzen 3 3100
PSU - Silverstone 500W 80+ Gold
SSD - Team Group 512 GB Sata
RAM - Corsair Vengeance LPX 2x8GB
Motherboard - Gigabyte B450 i Aorus pro wifi ITX
 
Sep 16, 2021
5
1
15
0
"is there a chance the motherboard is dead, perhaps the sticks knocked off a capacitor or something from the motherboard?"
Could be
Set the BIOS back to default.
Remove GPU, plug monitor into HDMI port
Reseat (and regrease )CPU.
Run it with 1 stick (if it'll work with 1), then the other.
See if it does anything different.
 
Reactions: 7Bites
Sep 16, 2021
3
0
10
0
"is there a chance the motherboard is dead, perhaps the sticks knocked off a capacitor or something from the motherboard?"
Could be
Set the BIOS back to default.
Remove GPU, plug monitor into HDMI port
Reseat (and regrease )CPU.
Run it with 1 stick (if it'll work with 1), then the other.
See if it does anything different.
Are there any signs that the motherboard is dead? I have an exhaust fan connected to the motherboard yet it still works, does it mean the motherboard is good?
My CPU doesn't have intergrated graphics, how can it work without a gpu?
 
Sep 16, 2021
5
1
15
0
Are there any signs that the motherboard is dead? I have an exhaust fan connected to the motherboard yet it still works, does it mean the motherboard is good?
My CPU doesn't have intergrated graphics, how can it work without a gpu?
"1 x DisplayPort, supporting a maximum resolution of 4096x2304@60 Hz
2 x HDMI ports, supporting a maximum resolution of 4096x2160@60 Hz(Note)
It's got onboard graphics ports
 

Vic 40

Titan
Ambassador
"1 x DisplayPort, supporting a maximum resolution of 4096x2304@60 Hz
2 x HDMI ports, supporting a maximum resolution of 4096x2160@60 Hz(Note)
It's got onboard graphics ports
No it doesn't, onboard gpu's are integrated into the cpu these days and his cpu doesn't have one, those ports are just there for if the cpu has an IGP.


@7Bites,

Maybe you can try and rebuild machine, when rebuilding take all neccesary components outside the case like even motherboard, do a "breadboard" and use only the cpu+motherboard+1xram+gpu+psu on a piece of non conductive underground and see if it will boot then. If it does place back into the case.
 

ASK THE COMMUNITY