Question PC doesn't boot up with 2 g.skill ram sticks installed

Jul 28, 2021
10
1
15
0
I've had this problem ever since I initially built the PC. I checked both rams in different slots and they were working, as long as they weren't installed simultaneously.

Some time ago, I decided to check if that was still an issue, so I plugged both rams in and my PC was working perfectly well for a few days. I managed to do a few passes of memtest86 and no errors were showing.

However, today the issue came back and my PC couldn't boot. All components lighted up for a few seconds and suddenly there was a distinct sound of the PC losing power. It kept trying to restart.

To add, the rams are of the same make and model, they were bought in a set.

What could be causing this?

EDIT: I updated the BIOS to the latest version but that didn't seem to help. I tried unplugging the cpu fan and took it off completely, that didn't help as well. But once I plugged it back in, it booted without any issues. I've read online that if the cpu fan is attached in a tight manner it can cause problems with the memory. Problem is that the PC didn't boot without the fan installed either, so I am still confused.

EDIT2: Got a few unexpected shutdowns, so I removed the second ram stick. No idea what's going on.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS