Question PC Doesn't boot with new GPU? (black screen - no signal)

Apr 11, 2020
1
0
10
0
Hi guys,

I'm trying to upgrade my old PC, not much of a heavy gamer but I play the odd mid spec game and don't need anything super high end but think my system could do with a GPU upgrade than the OEM that came with it. I have:

Generic 500W PSU
ASRock H67M-GE
i7-2600 CPU @ 3.40 GHz
16MB DDR-1333 MHz RAM
ATI Radeon HD 5400 Series

I installed a Sapphire RX 470 4GB to the spare PCI-3 x 16 2.0 slot but whenever I boot I get no signal and just a black screen, the fan on the GPU does start spinning though. I've tried the graphics card in my friends PC and it worked fine and I was able to load games and the screen via the HDMI port so I know the GPU works. It seems the mobo doesn't like the new card.

I looked for the latest BIOS of my mobo on https://www.asrock.com/mb/Intel/H67M-GE/index.asp#Support which says version 2.1 and when I tried to flash the UEFI setup utility says I already have this version installed - I uploaded a pic of the screen when I reboot here: https://ibb.co/LpgqJK7

I've googled to look for solutions but couldn't come up with anything else. It says the motherboard should be compatible with this GPU under this site:
https://www.pc-specs.com/gpu/ATI/R-400_Series/Radeon_RX_470_4GB/3598/Compatible_Motherboards

Although it's listed the H67M and H67M-GEHT model's which I don't know whether they make that much difference. Is there anything else I could try or do I need to find a new LGA 1155 compatible motherboard with 4 RAM slots so I can still use my CPU and RAM?

Just to add that I'm pretty new to all of this and most of what I learned was from this forum and online in general and trial & error, so this is my first time time "customising" a PC.

Thanks
 

ASK THE COMMUNITY

TRENDING THREADS